diff options
author | Pierre Sassoulas <pierre.sassoulas@gmail.com> | 2020-12-14 13:47:52 +0100 |
---|---|---|
committer | Pierre Sassoulas <pierre.sassoulas@gmail.com> | 2020-12-14 16:09:19 +0100 |
commit | 164dd5c8c210d05981e06e778f8c3da11de59101 (patch) | |
tree | 3f8e746ebf16ae46dc09270a0021d036921a43dc /setup.py | |
parent | 1736d3a9f0768f62b3d07f2d93a010eb92242633 (diff) | |
download | pylint-git-164dd5c8c210d05981e06e778f8c3da11de59101.tar.gz |
Fix pylint warning in bin/ and setup.py
Diffstat (limited to 'setup.py')
-rw-r--r-- | setup.py | 13 |
1 files changed, 5 insertions, 8 deletions
@@ -1,6 +1,3 @@ -# -*- coding: utf-8 -*- -#!/usr/bin/env python -# pylint: disable=W0404,W0622,W0613 # Copyright (c) 2006, 2009-2010, 2012-2014 LOGILAB S.A. (Paris, FRANCE) <contact@logilab.fr> # Copyright (c) 2010 Julien Jehannet <julien.jehannet@logilab.fr> # Copyright (c) 2012 FELD Boris <lothiraldan@gmail.com> @@ -26,16 +23,15 @@ # Licensed under the GPL: https://www.gnu.org/licenses/old-licenses/gpl-2.0.html # For details: https://github.com/PyCQA/pylint/blob/master/COPYING -"""Generic Setup script, takes package info from __pkginfo__.py file. -""" +"""Generic Setup script, takes package info from __pkginfo__.py file.""" + +# pylint: disable=import-outside-toplevel,arguments-differ,ungrouped-imports,exec-used + import os import sys from distutils.command.build_py import build_py from os.path import exists, isdir, join -__docformat__ = "restructuredtext en" - - try: from setuptools import setup from setuptools.command import easy_install as easy_install_lib @@ -50,6 +46,7 @@ except ImportError: easy_install_lib = None +__docformat__ = "restructuredtext en" base_dir = os.path.dirname(__file__) __pkginfo__ = {} |