summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorMarc Mueller <30130371+cdce8p@users.noreply.github.com>2021-02-12 15:40:40 +0100
committerPierre Sassoulas <pierre.sassoulas@gmail.com>2021-02-15 14:34:46 +0100
commit005cf2f317144f6503cfc8d00fbe6a201d0a8b8f (patch)
tree3f3943514f263d85e96e5952ae3f220878462460 /setup.py
parentfada206eef6349280c45b27e48b62c1c309c89c6 (diff)
downloadpylint-git-005cf2f317144f6503cfc8d00fbe6a201d0a8b8f.tar.gz
Drop support for Python 3.5 to fix typing
* Variable annotation (PEP 526) requires Python 3.6
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py2
1 files changed, 1 insertions, 1 deletions
diff --git a/setup.py b/setup.py
index 901b3ca84..e5dccc3a7 100644
--- a/setup.py
+++ b/setup.py
@@ -153,7 +153,7 @@ def install(**kwargs):
cmdclass=cmdclass,
extras_require=extras_require,
test_suite="test",
- python_requires="~=3.5",
+ python_requires="~=3.6",
setup_requires=pytest_runner,
tests_require=["pytest", "pytest-benchmark"],
project_urls=project_urls,