summaryrefslogtreecommitdiff
path: root/tests/extensions
diff options
context:
space:
mode:
authorPierre Sassoulas <pierre.sassoulas@gmail.com>2022-03-01 16:04:49 +0100
committerPierre Sassoulas <pierre.sassoulas@gmail.com>2022-03-24 13:06:15 +0100
commitec4a3f7f1eac9e605b35d1ac56680e1608c48be3 (patch)
tree5cf16665b7797bbe17e71f0f886a744e83bd034a /tests/extensions
parent9e0baf370a15fecf3360996a6a2ead688fc61894 (diff)
downloadpylint-git-ec4a3f7f1eac9e605b35d1ac56680e1608c48be3.tar.gz
Add a pre-commit hook to check the copyright notice
Fix the existing file so they have a notice. No header for setup.py or examples or doc
Diffstat (limited to 'tests/extensions')
-rw-r--r--tests/extensions/__init__.py3
-rw-r--r--tests/extensions/test_check_docs_utils.py2
-rw-r--r--tests/extensions/test_private_import.py4
3 files changed, 8 insertions, 1 deletions
diff --git a/tests/extensions/__init__.py b/tests/extensions/__init__.py
index e69de29bb..e8a8ff79f 100644
--- a/tests/extensions/__init__.py
+++ b/tests/extensions/__init__.py
@@ -0,0 +1,3 @@
+# Licensed under the GPL: https://www.gnu.org/licenses/old-licenses/gpl-2.0.html
+# For details: https://github.com/PyCQA/pylint/blob/main/LICENSE
+# Copyright (c) https://github.com/PyCQA/pylint/blob/main/CONTRIBUTORS.txt
diff --git a/tests/extensions/test_check_docs_utils.py b/tests/extensions/test_check_docs_utils.py
index abc0751d8..b14138a92 100644
--- a/tests/extensions/test_check_docs_utils.py
+++ b/tests/extensions/test_check_docs_utils.py
@@ -1,6 +1,6 @@
# Licensed under the GPL: https://www.gnu.org/licenses/old-licenses/gpl-2.0.html
# For details: https://github.com/PyCQA/pylint/blob/main/LICENSE
-# Copyright (c) https://github.com/PyCQA/pylint/graphs/contributors
+# Copyright (c) https://github.com/PyCQA/pylint/blob/main/CONTRIBUTORS.txt
"""Unit tests for utils functions in :mod:`pylint.extensions._check_docs_utils`."""
import astroid
diff --git a/tests/extensions/test_private_import.py b/tests/extensions/test_private_import.py
index 10648a8f9..d2d79947f 100644
--- a/tests/extensions/test_private_import.py
+++ b/tests/extensions/test_private_import.py
@@ -1,3 +1,7 @@
+# Licensed under the GPL: https://www.gnu.org/licenses/old-licenses/gpl-2.0.html
+# For details: https://github.com/PyCQA/pylint/blob/main/LICENSE
+# Copyright (c) https://github.com/PyCQA/pylint/blob/main/CONTRIBUTORS.txt
+
"""Tests the local module directory comparison logic which requires mocking file directories"""
from unittest.mock import patch