summaryrefslogtreecommitdiff
path: root/pylint/config/_pylint_config
diff options
context:
space:
mode:
Diffstat (limited to 'pylint/config/_pylint_config')
-rw-r--r--pylint/config/_pylint_config/__init__.py4
-rw-r--r--pylint/config/_pylint_config/generate_command.py11
-rw-r--r--pylint/config/_pylint_config/help_message.py4
-rw-r--r--pylint/config/_pylint_config/main.py4
-rw-r--r--pylint/config/_pylint_config/setup.py4
-rw-r--r--pylint/config/_pylint_config/utils.py4
6 files changed, 14 insertions, 17 deletions
diff --git a/pylint/config/_pylint_config/__init__.py b/pylint/config/_pylint_config/__init__.py
index 622d0dfe3..8d36bd88b 100644
--- a/pylint/config/_pylint_config/__init__.py
+++ b/pylint/config/_pylint_config/__init__.py
@@ -1,6 +1,6 @@
# Licensed under the GPL: https://www.gnu.org/licenses/old-licenses/gpl-2.0.html
-# For details: https://github.com/PyCQA/pylint/blob/main/LICENSE
-# Copyright (c) https://github.com/PyCQA/pylint/blob/main/CONTRIBUTORS.txt
+# For details: https://github.com/pylint-dev/pylint/blob/main/LICENSE
+# Copyright (c) https://github.com/pylint-dev/pylint/blob/main/CONTRIBUTORS.txt
"""Everything related to the 'pylint-config' command.
diff --git a/pylint/config/_pylint_config/generate_command.py b/pylint/config/_pylint_config/generate_command.py
index 110069b90..d1b73c99b 100644
--- a/pylint/config/_pylint_config/generate_command.py
+++ b/pylint/config/_pylint_config/generate_command.py
@@ -1,13 +1,12 @@
# Licensed under the GPL: https://www.gnu.org/licenses/old-licenses/gpl-2.0.html
-# For details: https://github.com/PyCQA/pylint/blob/main/LICENSE
-# Copyright (c) https://github.com/PyCQA/pylint/blob/main/CONTRIBUTORS.txt
+# For details: https://github.com/pylint-dev/pylint/blob/main/LICENSE
+# Copyright (c) https://github.com/pylint-dev/pylint/blob/main/CONTRIBUTORS.txt
"""Everything related to the 'pylint-config generate' command."""
from __future__ import annotations
-import warnings
from io import StringIO
from typing import TYPE_CHECKING
@@ -29,10 +28,8 @@ def generate_interactive_config(linter: PyLinter) -> None:
config_string = linter._generate_config_file(minimal=minimal)
else:
output_stream = StringIO()
- with warnings.catch_warnings():
- warnings.filterwarnings("ignore", category=DeprecationWarning)
- linter.generate_config(stream=output_stream, skipsections=("Commands",))
- config_string = output_stream.getvalue()
+ linter._generate_config(stream=output_stream, skipsections=("Commands",))
+ config_string = output_stream.getvalue()
if to_file:
with open(output_file_name, "w", encoding="utf-8") as f:
diff --git a/pylint/config/_pylint_config/help_message.py b/pylint/config/_pylint_config/help_message.py
index 15c9803e7..7ba947429 100644
--- a/pylint/config/_pylint_config/help_message.py
+++ b/pylint/config/_pylint_config/help_message.py
@@ -1,6 +1,6 @@
# Licensed under the GPL: https://www.gnu.org/licenses/old-licenses/gpl-2.0.html
-# For details: https://github.com/PyCQA/pylint/blob/main/LICENSE
-# Copyright (c) https://github.com/PyCQA/pylint/blob/main/CONTRIBUTORS.txt
+# For details: https://github.com/pylint-dev/pylint/blob/main/LICENSE
+# Copyright (c) https://github.com/pylint-dev/pylint/blob/main/CONTRIBUTORS.txt
"""Everything related to the 'pylint-config -h' command and subcommands."""
diff --git a/pylint/config/_pylint_config/main.py b/pylint/config/_pylint_config/main.py
index 716702df5..e562da2ef 100644
--- a/pylint/config/_pylint_config/main.py
+++ b/pylint/config/_pylint_config/main.py
@@ -1,6 +1,6 @@
# Licensed under the GPL: https://www.gnu.org/licenses/old-licenses/gpl-2.0.html
-# For details: https://github.com/PyCQA/pylint/blob/main/LICENSE
-# Copyright (c) https://github.com/PyCQA/pylint/blob/main/CONTRIBUTORS.txt
+# For details: https://github.com/pylint-dev/pylint/blob/main/LICENSE
+# Copyright (c) https://github.com/pylint-dev/pylint/blob/main/CONTRIBUTORS.txt
"""Everything related to the 'pylint-config' command."""
diff --git a/pylint/config/_pylint_config/setup.py b/pylint/config/_pylint_config/setup.py
index ae52b99ba..211f9bc6d 100644
--- a/pylint/config/_pylint_config/setup.py
+++ b/pylint/config/_pylint_config/setup.py
@@ -1,6 +1,6 @@
# Licensed under the GPL: https://www.gnu.org/licenses/old-licenses/gpl-2.0.html
-# For details: https://github.com/PyCQA/pylint/blob/main/LICENSE
-# Copyright (c) https://github.com/PyCQA/pylint/blob/main/CONTRIBUTORS.txt
+# For details: https://github.com/pylint-dev/pylint/blob/main/LICENSE
+# Copyright (c) https://github.com/pylint-dev/pylint/blob/main/CONTRIBUTORS.txt
"""Everything related to the setup of the 'pylint-config' command."""
diff --git a/pylint/config/_pylint_config/utils.py b/pylint/config/_pylint_config/utils.py
index cd5f8affe..70b2a8092 100644
--- a/pylint/config/_pylint_config/utils.py
+++ b/pylint/config/_pylint_config/utils.py
@@ -1,6 +1,6 @@
# Licensed under the GPL: https://www.gnu.org/licenses/old-licenses/gpl-2.0.html
-# For details: https://github.com/PyCQA/pylint/blob/main/LICENSE
-# Copyright (c) https://github.com/PyCQA/pylint/blob/main/CONTRIBUTORS.txt
+# For details: https://github.com/pylint-dev/pylint/blob/main/LICENSE
+# Copyright (c) https://github.com/pylint-dev/pylint/blob/main/CONTRIBUTORS.txt
"""Utils for the 'pylint-config' command."""