summaryrefslogtreecommitdiff
path: root/pyproject.toml
diff options
context:
space:
mode:
Diffstat (limited to 'pyproject.toml')
-rw-r--r--pyproject.toml38
1 files changed, 28 insertions, 10 deletions
diff --git a/pyproject.toml b/pyproject.toml
index bd542646b..940af4864 100644
--- a/pyproject.toml
+++ b/pyproject.toml
@@ -30,6 +30,7 @@ classifiers = [
"Topic :: Software Development :: Debuggers",
"Topic :: Software Development :: Quality Assurance",
"Topic :: Software Development :: Testing",
+ "Typing :: Typed"
]
requires-python = ">=3.7.2"
dependencies = [
@@ -55,17 +56,16 @@ spelling = ["pyenchant~=3.2"]
[project.urls]
"Docs: User Guide" = "https://pylint.readthedocs.io/en/latest/"
-"Source Code" = "https://github.com/PyCQA/pylint"
-"homepage" = "https://github.com/PyCQA/pylint"
+"Source Code" = "https://github.com/pylint-dev/pylint"
+"homepage" = "https://github.com/pylint-dev/pylint"
"What's New" = "https://pylint.readthedocs.io/en/latest/whatsnew/2/"
-"Bug Tracker" = "https://github.com/PyCQA/pylint/issues"
+"Bug Tracker" = "https://github.com/pylint-dev/pylint/issues"
"Discord Server" = "https://discord.com/invite/Egy6P8AMB5"
"Docs: Contributor Guide" = "https://pylint.readthedocs.io/en/latest/development_guide/contributor_guide/index.html"
[project.scripts]
pylint = "pylint:run_pylint"
pylint-config = "pylint:_run_pylint_config"
-epylint = "pylint:run_epylint"
pyreverse = "pylint:run_pyreverse"
symilar = "pylint:run_symilar"
@@ -76,7 +76,7 @@ license-files = ["LICENSE", "CONTRIBUTORS.txt"] # Keep in sync with setup.cfg
include = ["pylint*"]
[tool.setuptools.package-data]
-pylint = ["testutils/testing_pylintrc"]
+pylint = ["testutils/testing_pylintrc", "py.typed"]
[tool.setuptools.dynamic]
version = {attr = "pylint.__pkginfo__.__version__"}
@@ -132,11 +132,29 @@ module = [
]
[tool.ruff]
-select = ["E", "F", "W", "B"]
-ignore = [
- "B905", # Not enforced previousely
-]
-fixable = ["E", "F", "W", "B"]
+
# ruff is less lenient than pylint and does not make any exceptions
# (for docstrings, strings and comments in particular).
line-length = 115
+
+select = [
+ "E", # pycodestyle
+ "F", # pyflakes
+ "W", # pycodestyle
+ "B", # bugbear
+ "I", # isort
+ "RUF", # ruff
+]
+
+ignore = [
+ "B905", # `zip()` without an explicit `strict=` parameter
+]
+
+fixable = [
+ "E", # pycodestyle
+ "F", # pyflakes
+ "W", # pycodestyle
+ "B", # bugbear
+ "I", # isort
+ "RUF", # ruff
+]