summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSylvain Th?nault <sylvain.thenault@logilab.fr>2014-04-18 15:41:38 +0200
committerSylvain Th?nault <sylvain.thenault@logilab.fr>2014-04-18 15:41:38 +0200
commite3bfb0bd308be0bea85a0cc0b987a179daecb983 (patch)
treecae213ad0a0cc3fbeeed1f790b68631bac1113b3
parent8ae7a22ad67a416068068850c95f0f98e35e6072 (diff)
downloadpylint-e3bfb0bd308be0bea85a0cc0b987a179daecb983.tar.gz
pylint 1.1
-rw-r--r--ChangeLog8
-rw-r--r--__pkginfo__.py6
-rw-r--r--debian/changelog6
-rw-r--r--debian/control2
4 files changed, 16 insertions, 6 deletions
diff --git a/ChangeLog b/ChangeLog
index 68b980f..7c038cb 100644
--- a/ChangeLog
+++ b/ChangeLog
@@ -1,8 +1,7 @@
ChangeLog for Pylint
====================
---
-
+2014-04-18 -- 1.2.0
* Pass the current python paths to pylint process when invoked via
epylint. Fixes BitBucket issue #133.
@@ -94,6 +93,7 @@ ChangeLog for Pylint
* Do not attempt to analyze non python file, eg .so file (#122)
+
2013-12-22 -- 1.1.0
* Add new check for use of deprecated pragma directives "pylint:disable-msg"
or "pylint:enable-msg" (I0022, deprecated-pragma) which was previously
@@ -153,6 +153,7 @@ ChangeLog for Pylint
* Fix issue #55 (false-positive trailing-whitespace on Windows)
+
2013-08-06 -- 1.0.0
* Add check for the use of 'exec' function
@@ -1399,3 +1400,6 @@ ChangeLog for Pylint
2003-05-19 -- 0.1
* initial release
+
+
+
diff --git a/__pkginfo__.py b/__pkginfo__.py
index 0aa48a9..ea67fe6 100644
--- a/__pkginfo__.py
+++ b/__pkginfo__.py
@@ -19,14 +19,14 @@ import sys
modname = distname = 'pylint'
-numversion = (1, 1, 0)
+numversion = (1, 2, 0)
version = '.'.join([str(num) for num in numversion])
if sys.version_info < (2, 6):
- install_requires = ['logilab-common >= 0.53.0', 'astroid >= 1.0.1',
+ install_requires = ['logilab-common >= 0.53.0', 'astroid >= 1.1',
'StringFormat']
else:
- install_requires = ['logilab-common >= 0.53.0', 'astroid >= 1.0.1']
+ install_requires = ['logilab-common >= 0.53.0', 'astroid >= 1.1']
license = 'GPL'
description = "python code static checker"
diff --git a/debian/changelog b/debian/changelog
index f9d42f2..c52023c 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,3 +1,9 @@
+pylint (1.2.0-0) unstable; urgency=low
+
+ * new upstream release
+
+ -- Sylvain Thénault <sylvain.thenault@logilab.fr> Fri, 18 Apr 2014 15:32:32 +0200
+
pylint (1.1.0-1) unstable; urgency=low
* new upstream release
diff --git a/debian/control b/debian/control
index 313445a..442737d 100644
--- a/debian/control
+++ b/debian/control
@@ -19,7 +19,7 @@ Architecture: all
Depends: ${python:Depends},
${misc:Depends},
python-logilab-common (>= 0.53.0),
- python-astroid (>= 1.0.1)
+ python-astroid (>= 1.1)
Suggests: python-tk
XB-Python-Version: ${python:Versions}
Description: python code static checker and UML diagram generator