summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSylvain Th?nault <sylvain.thenault@logilab.fr>2013-12-20 11:15:12 +0100
committerSylvain Th?nault <sylvain.thenault@logilab.fr>2013-12-20 11:15:12 +0100
commite133f3fba933eacc307012ec09c835ebe1b5791c (patch)
treea912d1cb01f0a621f1b5d8eb99086c70446c5e0a
parent82d1534aaa0a09d9a021ab35d2d0e7e5ee226e7e (diff)
downloadpylint-e133f3fba933eacc307012ec09c835ebe1b5791c.tar.gz
[packaging] drop config for no more supported debian/ubuntu distributions
-rwxr-xr-xdebian.intrepid/rules79
-rwxr-xr-xdebian.jaunty/rules79
-rwxr-xr-xdebian.lenny/rules79
3 files changed, 0 insertions, 237 deletions
diff --git a/debian.intrepid/rules b/debian.intrepid/rules
deleted file mode 100755
index 81b90c3..0000000
--- a/debian.intrepid/rules
+++ /dev/null
@@ -1,79 +0,0 @@
-#!/usr/bin/make -f
-# Sample debian/rules that uses debhelper.
-# GNU copyright 1997 to 1999 by Joey Hess.
-#
-# adapted by Logilab for automatic generation by debianize
-# (part of the devtools project, http://www.logilab.org/projects/devtools)
-#
-# Copyright (c) 2003-2009 LOGILAB S.A. (Paris, FRANCE).
-# http://www.logilab.fr/ -- mailto:contact@logilab.fr
-
-# Uncomment this to turn on verbose mode.
-#export DH_VERBOSE=1
-
-build: build-stamp
-build-stamp:
- dh_testdir
- NO_SETUPTOOLS=1 python setup.py -q build
- touch build-stamp
-
-clean:
- dh_testdir
- dh_testroot
-
- NO_SETUPTOOLS=1 python setup.py clean
-
- find . -name "*.pyc" -delete
-
- rm -rf build
-
- dh_clean build-stamp
-
-install: build
- dh_testdir
- dh_testroot
- dh_clean -k
- dh_installdirs
-
- NO_SETUPTOOLS=1 python setup.py -q install --no-compile \
- --root=$(CURDIR)/debian/pylint \
-
-
- rm -rf debian/pylint/usr/lib/python*/*-packages/pylint/test
-
- # fixes shebangs
- for exec in pylint pylint-gui symilar ; do \
- if head -1 debian/pylint/usr/bin/$$exec | grep "^#! */usr/bin" | grep "python" >/dev/null ; then \
- sed -i "s@^#! */usr/bin/env \+python\$$@#!/usr/bin/python@" debian/pylint/usr/bin/$$exec; \
- fi ; \
- chmod a+x debian/pylint/usr/bin/$$exec; \
- done
-
- install -m 644 elisp/pylint.el debian/pylint/usr/share/emacs/site-lisp/pylint/
-
- # install tests
- #(cd test && find . -type f -not \( -path '*/CVS/*' -or -name '*.pyc' \) -exec install -D --mode=644 {} ../debian/pylint/usr/share/doc/pylint/test/{} \;)
-
-# Build architecture-independent files here.
-binary-indep: build install
- dh_testdir
- dh_testroot
- dh_install -i
- dh_pysupport -i
- dh_installchangelogs -i ChangeLog
- dh_installexamples -i
- dh_installdocs -i
- dh_installman -i
- dh_installemacsen
- dh_link -i
- dh_compress -i -X.py -X.ini -X.xml -Xtest
- dh_fixperms -i
- dh_installdeb -i
- dh_gencontrol -i
- dh_md5sums -i
- dh_builddeb -i
-
-binary-arch:
-
-binary: binary-indep
-.PHONY: build clean binary binary-indep binary-arch
diff --git a/debian.jaunty/rules b/debian.jaunty/rules
deleted file mode 100755
index 81b90c3..0000000
--- a/debian.jaunty/rules
+++ /dev/null
@@ -1,79 +0,0 @@
-#!/usr/bin/make -f
-# Sample debian/rules that uses debhelper.
-# GNU copyright 1997 to 1999 by Joey Hess.
-#
-# adapted by Logilab for automatic generation by debianize
-# (part of the devtools project, http://www.logilab.org/projects/devtools)
-#
-# Copyright (c) 2003-2009 LOGILAB S.A. (Paris, FRANCE).
-# http://www.logilab.fr/ -- mailto:contact@logilab.fr
-
-# Uncomment this to turn on verbose mode.
-#export DH_VERBOSE=1
-
-build: build-stamp
-build-stamp:
- dh_testdir
- NO_SETUPTOOLS=1 python setup.py -q build
- touch build-stamp
-
-clean:
- dh_testdir
- dh_testroot
-
- NO_SETUPTOOLS=1 python setup.py clean
-
- find . -name "*.pyc" -delete
-
- rm -rf build
-
- dh_clean build-stamp
-
-install: build
- dh_testdir
- dh_testroot
- dh_clean -k
- dh_installdirs
-
- NO_SETUPTOOLS=1 python setup.py -q install --no-compile \
- --root=$(CURDIR)/debian/pylint \
-
-
- rm -rf debian/pylint/usr/lib/python*/*-packages/pylint/test
-
- # fixes shebangs
- for exec in pylint pylint-gui symilar ; do \
- if head -1 debian/pylint/usr/bin/$$exec | grep "^#! */usr/bin" | grep "python" >/dev/null ; then \
- sed -i "s@^#! */usr/bin/env \+python\$$@#!/usr/bin/python@" debian/pylint/usr/bin/$$exec; \
- fi ; \
- chmod a+x debian/pylint/usr/bin/$$exec; \
- done
-
- install -m 644 elisp/pylint.el debian/pylint/usr/share/emacs/site-lisp/pylint/
-
- # install tests
- #(cd test && find . -type f -not \( -path '*/CVS/*' -or -name '*.pyc' \) -exec install -D --mode=644 {} ../debian/pylint/usr/share/doc/pylint/test/{} \;)
-
-# Build architecture-independent files here.
-binary-indep: build install
- dh_testdir
- dh_testroot
- dh_install -i
- dh_pysupport -i
- dh_installchangelogs -i ChangeLog
- dh_installexamples -i
- dh_installdocs -i
- dh_installman -i
- dh_installemacsen
- dh_link -i
- dh_compress -i -X.py -X.ini -X.xml -Xtest
- dh_fixperms -i
- dh_installdeb -i
- dh_gencontrol -i
- dh_md5sums -i
- dh_builddeb -i
-
-binary-arch:
-
-binary: binary-indep
-.PHONY: build clean binary binary-indep binary-arch
diff --git a/debian.lenny/rules b/debian.lenny/rules
deleted file mode 100755
index 81b90c3..0000000
--- a/debian.lenny/rules
+++ /dev/null
@@ -1,79 +0,0 @@
-#!/usr/bin/make -f
-# Sample debian/rules that uses debhelper.
-# GNU copyright 1997 to 1999 by Joey Hess.
-#
-# adapted by Logilab for automatic generation by debianize
-# (part of the devtools project, http://www.logilab.org/projects/devtools)
-#
-# Copyright (c) 2003-2009 LOGILAB S.A. (Paris, FRANCE).
-# http://www.logilab.fr/ -- mailto:contact@logilab.fr
-
-# Uncomment this to turn on verbose mode.
-#export DH_VERBOSE=1
-
-build: build-stamp
-build-stamp:
- dh_testdir
- NO_SETUPTOOLS=1 python setup.py -q build
- touch build-stamp
-
-clean:
- dh_testdir
- dh_testroot
-
- NO_SETUPTOOLS=1 python setup.py clean
-
- find . -name "*.pyc" -delete
-
- rm -rf build
-
- dh_clean build-stamp
-
-install: build
- dh_testdir
- dh_testroot
- dh_clean -k
- dh_installdirs
-
- NO_SETUPTOOLS=1 python setup.py -q install --no-compile \
- --root=$(CURDIR)/debian/pylint \
-
-
- rm -rf debian/pylint/usr/lib/python*/*-packages/pylint/test
-
- # fixes shebangs
- for exec in pylint pylint-gui symilar ; do \
- if head -1 debian/pylint/usr/bin/$$exec | grep "^#! */usr/bin" | grep "python" >/dev/null ; then \
- sed -i "s@^#! */usr/bin/env \+python\$$@#!/usr/bin/python@" debian/pylint/usr/bin/$$exec; \
- fi ; \
- chmod a+x debian/pylint/usr/bin/$$exec; \
- done
-
- install -m 644 elisp/pylint.el debian/pylint/usr/share/emacs/site-lisp/pylint/
-
- # install tests
- #(cd test && find . -type f -not \( -path '*/CVS/*' -or -name '*.pyc' \) -exec install -D --mode=644 {} ../debian/pylint/usr/share/doc/pylint/test/{} \;)
-
-# Build architecture-independent files here.
-binary-indep: build install
- dh_testdir
- dh_testroot
- dh_install -i
- dh_pysupport -i
- dh_installchangelogs -i ChangeLog
- dh_installexamples -i
- dh_installdocs -i
- dh_installman -i
- dh_installemacsen
- dh_link -i
- dh_compress -i -X.py -X.ini -X.xml -Xtest
- dh_fixperms -i
- dh_installdeb -i
- dh_gencontrol -i
- dh_md5sums -i
- dh_builddeb -i
-
-binary-arch:
-
-binary: binary-indep
-.PHONY: build clean binary binary-indep binary-arch