summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorClaudiu Popa <pcmanticore@gmail.com>2014-12-04 16:55:26 +0200
committerClaudiu Popa <pcmanticore@gmail.com>2014-12-04 16:55:26 +0200
commit08108868ea4ffb0a8dc630ef10065f7c847c2182 (patch)
tree50605b61f33b584aca26f3ad35c5e9f1522ac40a
parent3688d8c4ccdabfe7d4711ed79aa395207690576e (diff)
parent9a8779b642665a31c6a551a4f0097178a3df0bc1 (diff)
downloadpylint-08108868ea4ffb0a8dc630ef10065f7c847c2182.tar.gz
Merged in s0undt3ch/pylint/hotfix/py26-compat (pull request #206)
New style tuple syntax is only supported on Python >= 2.7
-rw-r--r--setup.py4
1 files changed, 2 insertions, 2 deletions
diff --git a/setup.py b/setup.py
index b4f8240..9fc40d7 100644
--- a/setup.py
+++ b/setup.py
@@ -120,8 +120,8 @@ class MyInstallLib(install_lib.install_lib):
for directory in include_dirs:
dest = join(self.install_dir, base, directory)
if sys.version_info >= (3, 0):
- exclude = {'invalid_encoded_data*',
- 'unknown_encoding*'}
+ exclude = set(['invalid_encoded_data*',
+ 'unknown_encoding*'])
else:
exclude = set()
shutil.rmtree(dest, ignore_errors=True)