summaryrefslogtreecommitdiff
path: root/tox.ini
diff options
context:
space:
mode:
authorJohn Anderson <sontek@gmail.com>2015-06-20 00:05:40 -0700
committerJohn Anderson <sontek@gmail.com>2015-06-20 00:05:40 -0700
commitcd4b7b6e3a8713ad8d2a9eb63bc1bdc07dd93a18 (patch)
tree458fbbccc9d677d59721e22add650dab9162de57 /tox.ini
parent8a981aa265dca09f76db2b734cd88d6654672cdf (diff)
parentace2cd339207c9739ef5ee0d4412a930b9bf571c (diff)
downloadpymemcache-cd4b7b6e3a8713ad8d2a9eb63bc1bdc07dd93a18.tar.gz
Merge branch 'flake8' of https://github.com/sontek/pymemcache into switch_to_pytest
Conflicts: setup.cfg setup.py tox.ini
Diffstat (limited to 'tox.ini')
-rw-r--r--tox.ini7
1 files changed, 6 insertions, 1 deletions
diff --git a/tox.ini b/tox.ini
index 09c0e1f..9524d29 100644
--- a/tox.ini
+++ b/tox.ini
@@ -1,5 +1,5 @@
[tox]
-envlist = py26, py27, pypy, py33, py34, docs
+envlist = py26, py27, pypy, py33, py34, docs, flake8
[testenv]
commands =
@@ -7,6 +7,11 @@ commands =
pip install -e .
py.test {posargs}
+[testenv:flake8]
+commands =
+ pip install flake8
+ flake8 .
+
[testenv:docs]
commands =
pip install -r docs-requirements.txt