summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHynek Schlawack <hs@ox.cx>2015-05-19 20:04:51 +0200
committerHynek Schlawack <hs@ox.cx>2015-05-19 20:04:51 +0200
commit389f78bc3bfe1862e0c5226a9955ca33e5c4eca8 (patch)
tree1356b5642b12d73dc7f86b68d9cc31d12e43224e
parent410b6d306693a33bac0d89eee010c077135e7893 (diff)
parent98316d77951dd908aece2c0ecb73844d489e0b03 (diff)
downloadpyopenssl-389f78bc3bfe1862e0c5226a9955ca33e5c4eca8.tar.gz
Merge pull request #127 from lvh/test-metadata
Add a meta testenv for metadata: style & packaging
-rw-r--r--.travis.yml7
-rw-r--r--setup.cfg3
-rw-r--r--tox.ini14
3 files changed, 23 insertions, 1 deletions
diff --git a/.travis.yml b/.travis.yml
index f49e780..1924463 100644
--- a/.travis.yml
+++ b/.travis.yml
@@ -53,11 +53,17 @@ matrix:
- python: "2.7"
env: TOXENV=pypi-readme
+ - python: "2.7"
+ env: TOXENV=flake8
+ - python: "2.7"
+ env: TOXENV=pyroma
+
# Let the cryptography master builds fail because they might be triggered by
# cryptography changes beyond our control.
# Also allow OS X and 0.9.8 to fail at the moment while we fix these new
# build configurations.
+ # Also allow lint to fail while we fix existing lint.
allow_failures:
- language: generic
os: osx
@@ -68,6 +74,7 @@ matrix:
- env: TOXENV=py34-cryptographyMaster
- env: TOXENV=pypy-cryptographyMaster
- env: OPENSSL=0.9.8 TOXENV=py27
+ - env: TOXENV=flake8
install:
- |
diff --git a/setup.cfg b/setup.cfg
index ec1218d..a22d598 100644
--- a/setup.cfg
+++ b/setup.cfg
@@ -11,3 +11,6 @@ build-requires = lynx openssl-devel python-devel python-sphinx
group = Development/Libraries
build_script = rpm/build_script
doc-files = doc/_build/html
+
+[flake8]
+ignore = E303
diff --git a/tox.ini b/tox.ini
index a4cab37..a2b1d72 100644
--- a/tox.ini
+++ b/tox.ini
@@ -1,5 +1,5 @@
[tox]
-envlist = {pypy,py26,py27,py33,py34}{,-cryptographyMaster},pypi-readme,check-manifest
+envlist = {pypy,py26,py27,py33,py34}{,-cryptographyMaster},pypi-readme,check-manifest,flake8,pyroma
[testenv]
whitelist_externals =
@@ -20,6 +20,18 @@ commands =
coverage run --branch --source=OpenSSL setup.py test
coverage report -m
+[testenv:flake8]
+deps =
+ flake8
+commands =
+ flake8 OpenSSL
+
+[testenv:pyroma]
+deps =
+ pyroma>=1.6 # <1.6 had bogus return values.
+commands =
+ pyroma -d .
+
[testenv:pypi-readme]
deps =
readme