summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJean-Paul Calderone <exarkun@twistedmatrix.com>2014-04-17 10:41:27 -0400
committerJean-Paul Calderone <exarkun@twistedmatrix.com>2014-04-17 10:41:27 -0400
commit434d03bbb3255cc313680826939801760b351d2a (patch)
tree6b4a21fd56249224cc35dbe00fa9eabe6c2aedc0
parentf93ee8ab37d91a1f3de9d64e5d4e4698c0fb9bbe (diff)
parent3bcc881c6008eb23f3e54c1d8ffd50da4ae71311 (diff)
downloadpyopenssl-434d03bbb3255cc313680826939801760b351d2a.tar.gz
Merge pull request #97 from pyca/more-openssl-testing
Do a little testing against OpenSSL 0.9.8.
-rw-r--r--.travis.yml42
1 files changed, 33 insertions, 9 deletions
diff --git a/.travis.yml b/.travis.yml
index 0a8bbab..595e37c 100644
--- a/.travis.yml
+++ b/.travis.yml
@@ -2,7 +2,6 @@ language: python
os:
- linux
- - osx
python:
- "pypy"
@@ -13,18 +12,35 @@ python:
matrix:
include:
+ # Also run the tests against cryptography master.
- python: "2.6"
- env: CRYPTOGRAPHY_GIT_MASTER=true
+ env:
+ CRYPTOGRAPHY_GIT_MASTER=true
- python: "2.7"
- env: CRYPTOGRAPHY_GIT_MASTER=true
+ env:
+ CRYPTOGRAPHY_GIT_MASTER=true
- python: "3.2"
- env: CRYPTOGRAPHY_GIT_MASTER=true
+ env:
+ CRYPTOGRAPHY_GIT_MASTER=true
- python: "3.3"
- env: CRYPTOGRAPHY_GIT_MASTER=true
+ env:
+ CRYPTOGRAPHY_GIT_MASTER=true
- python: "pypy"
- env: CRYPTOGRAPHY_GIT_MASTER=true
+ env:
+ CRYPTOGRAPHY_GIT_MASTER=true
+
+ # Also run at least a little bit against an older version of OpenSSL.
+ - python: "2.7"
+ env:
+ OPENSSL=0.9.8
+
+ # Let the cryptography master builds fail because they might be triggered by
+ # cryptography changes beyond our control.
allow_failures:
- - env: CRYPTOGRAPHY_GIT_MASTER=true
+ - env:
+ CRYPTOGRAPHY_GIT_MASTER=true
+ - env:
+ OPENSSL=0.9.8
before_install:
- if [ -n "$CRYPTOGRAPHY_GIT_MASTER" ]; then pip install git+https://github.com/pyca/cryptography.git;fi
@@ -41,8 +57,16 @@ install:
- pip install coveralls coverage
script:
- - coverage run --branch --source=OpenSSL setup.py bdist_wheel test
- - coverage report -m
+ - |
+ if [[ "${OPENSSL}" == "0.9.8" ]]; then
+ sudo add-apt-repository "deb http://archive.ubuntu.com/ubuntu/ lucid main"
+ sudo apt-get -y update
+ sudo apt-get install -y --force-yes libssl-dev/lucid
+ fi
+ - |
+ coverage run --branch --source=OpenSSL setup.py bdist_wheel test
+ - |
+ coverage report -m
after_success:
- coveralls