summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJean-Paul Calderone <exarkun@twistedmatrix.com>2014-04-17 16:13:00 -0400
committerJean-Paul Calderone <exarkun@twistedmatrix.com>2014-04-17 17:40:53 -0400
commit727b35e42b6b8ae8be2b6bd814c2b797cfe23b2b (patch)
tree9076725718c086b3be57c7b1f208bc13cf1cb464
parent434d03bbb3255cc313680826939801760b351d2a (diff)
downloadpyopenssl-727b35e42b6b8ae8be2b6bd814c2b797cfe23b2b.tar.gz
Try explicitly installing the Python dependencies since "setup.py test" does not install them in a way that makes them available later.
-rw-r--r--.travis.yml2
1 files changed, 2 insertions, 0 deletions
diff --git a/.travis.yml b/.travis.yml
index 595e37c..62565d1 100644
--- a/.travis.yml
+++ b/.travis.yml
@@ -64,6 +64,8 @@ script:
sudo apt-get install -y --force-yes libssl-dev/lucid
fi
- |
+ pip install -e .
+ - |
coverage run --branch --source=OpenSSL setup.py bdist_wheel test
- |
coverage report -m