summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJean-Paul Calderone <exarkun@twistedmatrix.com>2014-04-17 10:07:34 -0400
committerJean-Paul Calderone <exarkun@twistedmatrix.com>2014-04-17 10:07:34 -0400
commita2d7e09c195f583e4d223489b620c418ca9992e7 (patch)
tree15427dcaab326ed92dc84ea9787eb21330803469
parentf93ee8ab37d91a1f3de9d64e5d4e4698c0fb9bbe (diff)
downloadpyopenssl-a2d7e09c195f583e4d223489b620c418ca9992e7.tar.gz
take a stab at running tests against openssl 0.9.8 as well
-rw-r--r--.travis.yml40
1 files changed, 31 insertions, 9 deletions
diff --git a/.travis.yml b/.travis.yml
index 0a8bbab..543dc50 100644
--- a/.travis.yml
+++ b/.travis.yml
@@ -2,7 +2,6 @@ language: python
os:
- linux
- - osx
python:
- "pypy"
@@ -13,18 +12,33 @@ python:
matrix:
include:
+ # Also run the tests against cryptography master.
- python: "2.6"
- env: CRYPTOGRAPHY_GIT_MASTER=true
+ env:
+ CRYPTOGRAPHY_GIT_MASTER=true
- python: "2.7"
- env: CRYPTOGRAPHY_GIT_MASTER=true
+ env:
+ CRYPTOGRAPHY_GIT_MASTER=true
- python: "3.2"
- env: CRYPTOGRAPHY_GIT_MASTER=true
+ env:
+ CRYPTOGRAPHY_GIT_MASTER=true
- python: "3.3"
- env: CRYPTOGRAPHY_GIT_MASTER=true
+ env:
+ CRYPTOGRAPHY_GIT_MASTER=true
- python: "pypy"
- env: CRYPTOGRAPHY_GIT_MASTER=true
+ env:
+ CRYPTOGRAPHY_GIT_MASTER=true
+
+ # Also run at least a little bit against an older version of OpenSSL.
+ - python: "2.7"
+ env:
+ OPENSSL=0.9.8
+
+ # Let the cryptography master builds fail because they might be triggered by
+ # cryptography changes beyond our control.
allow_failures:
- - env: CRYPTOGRAPHY_GIT_MASTER=true
+ - env:
+ CRYPTOGRAPHY_GIT_MASTER=true
before_install:
- if [ -n "$CRYPTOGRAPHY_GIT_MASTER" ]; then pip install git+https://github.com/pyca/cryptography.git;fi
@@ -41,8 +55,16 @@ install:
- pip install coveralls coverage
script:
- - coverage run --branch --source=OpenSSL setup.py bdist_wheel test
- - coverage report -m
+ - |
+ if [[ "${OPENSSL}" == "0.9.8" ]]; then
+ sudo add-apt-repository "deb http://archive.ubuntu.com/ubuntu/ lucid main"
+ sudo apt-get -y update
+ sudo apt-get install -y --force-yes libssl-dev/lucid
+ fi
+ - |
+ coverage run --branch --source=OpenSSL setup.py bdist_wheel test
+ - |
+ coverage report -m
after_success:
- coveralls