summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJean-Paul Calderone <exarkun@twistedmatrix.com>2014-04-16 18:42:16 -0400
committerJean-Paul Calderone <exarkun@twistedmatrix.com>2014-04-16 18:42:16 -0400
commitf93ee8ab37d91a1f3de9d64e5d4e4698c0fb9bbe (patch)
tree08f125a719e0546e524d80cdc691127fe234631c
parentd254e2426eacdc9dc37497ac349d9b49ae808e95 (diff)
parent8dc60320bfa8d81a5a90f5f4a9957a4e652c6c90 (diff)
downloadpyopenssl-f93ee8ab37d91a1f3de9d64e5d4e4698c0fb9bbe.tar.gz
Merge pull request #94 from pyca/coveralls
Integrate with Coveralls
-rw-r--r--.travis.yml13
-rw-r--r--README.rst (renamed from README)3
2 files changed, 15 insertions, 1 deletions
diff --git a/.travis.yml b/.travis.yml
index 52f1032..0a8bbab 100644
--- a/.travis.yml
+++ b/.travis.yml
@@ -36,5 +36,16 @@ install:
# travis.
- pip install wheel
+ # Also install some tools for measuring code coverage and sending the results
+ # to coveralls.
+ - pip install coveralls coverage
+
script:
- - python setup.py bdist_wheel test
+ - coverage run --branch --source=OpenSSL setup.py bdist_wheel test
+ - coverage report -m
+
+after_success:
+ - coveralls
+
+notifications:
+ email: false
diff --git a/README b/README.rst
index 1b2a093..de9aa4e 100644
--- a/README
+++ b/README.rst
@@ -7,3 +7,6 @@ See the file INSTALL for installation instructions.
See http://github.com/pyca/pyopenssl for development.
See https://mail.python.org/mailman/listinfo/pyopenssl-users for the discussion mailing list.
+
+.. image:: https://coveralls.io/repos/pyca/pyopenssl/badge.png
+ :target: https://coveralls.io/r/pyca/pyopenssl