summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJean-Paul Calderone <exarkun@twistedmatrix.com>2014-01-11 07:30:42 -0500
committerJean-Paul Calderone <exarkun@twistedmatrix.com>2014-01-11 07:30:42 -0500
commit11bf4b911d0f154ff1934d53daeedc1c7b06ae44 (patch)
treef2d5c64dde25f6447352c371915e11f4d2a58920
parentd27be802ffcc32d8d4786f2904c17a296e28edf6 (diff)
downloadpyopenssl-11bf4b911d0f154ff1934d53daeedc1c7b06ae44.tar.gz
Try using setuptools to help run the tests.
-rw-r--r--.travis.yml2
-rwxr-xr-xsetup.py3
2 files changed, 3 insertions, 2 deletions
diff --git a/.travis.yml b/.travis.yml
index 514de9d..81916ca 100644
--- a/.travis.yml
+++ b/.travis.yml
@@ -16,4 +16,4 @@ install:
- pip install --verbose unittest2
script:
- - unit2 discover -v
+ - python setup.py test
diff --git a/setup.py b/setup.py
index 078646b..ac53487 100755
--- a/setup.py
+++ b/setup.py
@@ -59,4 +59,5 @@ High-level wrapper around a subset of the OpenSSL library, includes
'Topic :: Security :: Cryptography',
'Topic :: Software Development :: Libraries :: Python Modules',
'Topic :: System :: Networking',
- ])
+ ],
+ test_suite="OpenSSL.test")