summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorJean-Paul Calderone <exarkun@twistedmatrix.com>2013-02-09 09:53:45 -0800
committerJean-Paul Calderone <exarkun@twistedmatrix.com>2013-02-09 09:53:45 -0800
commit084b7525dd4aed453aa36cffd586e8cb5c87c000 (patch)
treeecf411f81177412e1b5d6e48e7c46505d94650a5 /setup.py
parent8210b921ca89775b8773d03123fee77c7fad99e5 (diff)
downloadpyopenssl-084b7525dd4aed453aa36cffd586e8cb5c87c000.tar.gz
Move the crypto extension module aside to make way for an incremental rewrite in Python
Diffstat (limited to 'setup.py')
-rwxr-xr-xsetup.py7
1 files changed, 3 insertions, 4 deletions
diff --git a/setup.py b/setup.py
index 142d03c..6366b48 100755
--- a/setup.py
+++ b/setup.py
@@ -17,21 +17,20 @@ from distutils.command.build_ext import build_ext
# XXX Deduplicate this
__version__ = '0.13'
-crypto_src = ['OpenSSL/crypto/crypto.c', 'OpenSSL/crypto/x509.c',
+xcrypto_src = ['OpenSSL/crypto/crypto.c', 'OpenSSL/crypto/x509.c',
'OpenSSL/crypto/x509name.c', 'OpenSSL/crypto/pkey.c',
'OpenSSL/crypto/x509store.c', 'OpenSSL/crypto/x509req.c',
'OpenSSL/crypto/x509ext.c', 'OpenSSL/crypto/pkcs7.c',
'OpenSSL/crypto/pkcs12.c', 'OpenSSL/crypto/netscape_spki.c',
'OpenSSL/crypto/revoked.c', 'OpenSSL/crypto/crl.c',
'OpenSSL/util.c']
-crypto_dep = ['OpenSSL/crypto/crypto.h', 'OpenSSL/crypto/x509.h',
+xcrypto_dep = ['OpenSSL/crypto/crypto.h', 'OpenSSL/crypto/x509.h',
'OpenSSL/crypto/x509name.h', 'OpenSSL/crypto/pkey.h',
'OpenSSL/crypto/x509store.h', 'OpenSSL/crypto/x509req.h',
'OpenSSL/crypto/x509ext.h', 'OpenSSL/crypto/pkcs7.h',
'OpenSSL/crypto/pkcs12.h', 'OpenSSL/crypto/netscape_spki.h',
'OpenSSL/crypto/revoked.h', 'OpenSSL/crypto/crl.h',
'OpenSSL/util.h']
-rand_dep = ['OpenSSL/util.h']
ssl_src = ['OpenSSL/ssl/connection.c', 'OpenSSL/ssl/context.c', 'OpenSSL/ssl/ssl.c',
'OpenSSL/ssl/session.c', 'OpenSSL/util.c']
ssl_dep = ['OpenSSL/ssl/connection.h', 'OpenSSL/ssl/context.h', 'OpenSSL/ssl/ssl.h',
@@ -194,7 +193,7 @@ def mkExtension(name):
setup(name='pyOpenSSL', version=__version__,
packages = ['OpenSSL'],
package_dir = {'OpenSSL': 'OpenSSL'},
- ext_modules = [mkExtension('crypto'), mkExtension('SSL')],
+ ext_modules = [mkExtension('xcrypto'), mkExtension('SSL')],
py_modules = ['OpenSSL.__init__', 'OpenSSL.tsafe',
'OpenSSL.rand',
'OpenSSL.version', 'OpenSSL.test.__init__',