summaryrefslogtreecommitdiff
path: root/.travis.yml
diff options
context:
space:
mode:
Diffstat (limited to '.travis.yml')
-rw-r--r--.travis.yml57
1 files changed, 55 insertions, 2 deletions
diff --git a/.travis.yml b/.travis.yml
index 68149b4..595e37c 100644
--- a/.travis.yml
+++ b/.travis.yml
@@ -2,7 +2,6 @@ language: python
os:
- linux
- - osx
python:
- "pypy"
@@ -11,6 +10,41 @@ python:
- "3.2"
- "3.3"
+matrix:
+ include:
+ # Also run the tests against cryptography master.
+ - python: "2.6"
+ env:
+ CRYPTOGRAPHY_GIT_MASTER=true
+ - python: "2.7"
+ env:
+ CRYPTOGRAPHY_GIT_MASTER=true
+ - python: "3.2"
+ env:
+ CRYPTOGRAPHY_GIT_MASTER=true
+ - python: "3.3"
+ env:
+ CRYPTOGRAPHY_GIT_MASTER=true
+ - python: "pypy"
+ env:
+ CRYPTOGRAPHY_GIT_MASTER=true
+
+ # Also run at least a little bit against an older version of OpenSSL.
+ - python: "2.7"
+ env:
+ OPENSSL=0.9.8
+
+ # Let the cryptography master builds fail because they might be triggered by
+ # cryptography changes beyond our control.
+ allow_failures:
+ - env:
+ CRYPTOGRAPHY_GIT_MASTER=true
+ - env:
+ OPENSSL=0.9.8
+
+before_install:
+ - if [ -n "$CRYPTOGRAPHY_GIT_MASTER" ]; then pip install git+https://github.com/pyca/cryptography.git;fi
+
install:
# Install the wheel library explicitly here. It is not really a setup
# dependency. It is not an install dependency. It is only a dependency for
@@ -18,5 +52,24 @@ install:
# travis.
- pip install wheel
+ # Also install some tools for measuring code coverage and sending the results
+ # to coveralls.
+ - pip install coveralls coverage
+
script:
- - python setup.py bdist_wheel test
+ - |
+ if [[ "${OPENSSL}" == "0.9.8" ]]; then
+ sudo add-apt-repository "deb http://archive.ubuntu.com/ubuntu/ lucid main"
+ sudo apt-get -y update
+ sudo apt-get install -y --force-yes libssl-dev/lucid
+ fi
+ - |
+ coverage run --branch --source=OpenSSL setup.py bdist_wheel test
+ - |
+ coverage report -m
+
+after_success:
+ - coveralls
+
+notifications:
+ email: false