summaryrefslogtreecommitdiff
path: root/.travis.yml
diff options
context:
space:
mode:
Diffstat (limited to '.travis.yml')
-rw-r--r--.travis.yml13
1 files changed, 12 insertions, 1 deletions
diff --git a/.travis.yml b/.travis.yml
index 52f1032..0a8bbab 100644
--- a/.travis.yml
+++ b/.travis.yml
@@ -36,5 +36,16 @@ install:
# travis.
- pip install wheel
+ # Also install some tools for measuring code coverage and sending the results
+ # to coveralls.
+ - pip install coveralls coverage
+
script:
- - python setup.py bdist_wheel test
+ - coverage run --branch --source=OpenSSL setup.py bdist_wheel test
+ - coverage report -m
+
+after_success:
+ - coveralls
+
+notifications:
+ email: false