summaryrefslogtreecommitdiff
path: root/tox.ini
diff options
context:
space:
mode:
Diffstat (limited to 'tox.ini')
-rw-r--r--tox.ini14
1 files changed, 13 insertions, 1 deletions
diff --git a/tox.ini b/tox.ini
index a4cab37..a2b1d72 100644
--- a/tox.ini
+++ b/tox.ini
@@ -1,5 +1,5 @@
[tox]
-envlist = {pypy,py26,py27,py33,py34}{,-cryptographyMaster},pypi-readme,check-manifest
+envlist = {pypy,py26,py27,py33,py34}{,-cryptographyMaster},pypi-readme,check-manifest,flake8,pyroma
[testenv]
whitelist_externals =
@@ -20,6 +20,18 @@ commands =
coverage run --branch --source=OpenSSL setup.py test
coverage report -m
+[testenv:flake8]
+deps =
+ flake8
+commands =
+ flake8 OpenSSL
+
+[testenv:pyroma]
+deps =
+ pyroma>=1.6 # <1.6 had bogus return values.
+commands =
+ pyroma -d .
+
[testenv:pypi-readme]
deps =
readme