summaryrefslogtreecommitdiff
path: root/tox.ini
diff options
context:
space:
mode:
Diffstat (limited to 'tox.ini')
-rw-r--r--tox.ini10
1 files changed, 7 insertions, 3 deletions
diff --git a/tox.ini b/tox.ini
index 5d755b8..2164039 100644
--- a/tox.ini
+++ b/tox.ini
@@ -1,5 +1,5 @@
[tox]
-envlist = {pypy,py26,py27,py33,py34}{,-cryptographyMaster},pypi-readme,check-manifest,lint
+envlist = {pypy,py26,py27,py33,py34}{,-cryptographyMaster},pypi-readme,check-manifest,pyflakes,pyroma
[testenv]
whitelist_externals =
@@ -20,12 +20,16 @@ commands =
coverage run --branch --source=OpenSSL setup.py test
coverage report -m
-[testenv:lint]
+[testenv:pyflakes]
deps =
pyflakes
- pyroma>=1.6 # <1.6 had bogus return values.
commands =
pyflakes OpenSSL
+
+[testenv:pyroma]
+deps =
+ pyroma>=1.6 # <1.6 had bogus return values.
+commands =
pyroma -d .
[testenv:pypi-readme]