summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorptmcg <ptmcg@austin.rr.com>2019-11-03 21:00:13 -0600
committerptmcg <ptmcg@austin.rr.com>2019-11-03 21:00:13 -0600
commit89be5c81b106f4fed9a7b815841bdcf85f870297 (patch)
treea942423d10b17133db0740451d2af3eb57065cf5
parent021888d2686a498e3208543ab9eeca3c146848d3 (diff)
downloadpyparsing-git-89be5c81b106f4fed9a7b815841bdcf85f870297.tar.gz
Updates for 2.4.3 release - pathlib not Py2-compatible
-rw-r--r--setup.py5
1 files changed, 2 insertions, 3 deletions
diff --git a/setup.py b/setup.py
index 60ac281..2740521 100644
--- a/setup.py
+++ b/setup.py
@@ -6,11 +6,10 @@ from setuptools import setup
from pyparsing import __version__ as pyparsing_version
# The directory containing this file
-import pathlib
-HERE = pathlib.Path(__file__).parent
+README_name = __file__.replace("setup.py", "README.rst")
# The text of the README file
-with (HERE / "README.rst").open() as README:
+with open(README_name) as README:
pyparsing_main_doc = README.read()
modules = ["pyparsing",]