summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorptmcg <ptmcg@austin.rr.com>2019-09-02 17:19:32 -0500
committerptmcg <ptmcg@austin.rr.com>2019-09-02 17:19:32 -0500
commit418f0361891e902616912e7d016140505984fdf5 (patch)
tree5d30b93857f27defe6591e8f945d18e69b405e3a
parent29764ebd033a0a52a4657f77b06acaf070c9e58d (diff)
downloadpyparsing-git-418f0361891e902616912e7d016140505984fdf5.tar.gz
Add long_description for setup.py; add py3.8-dev and pypy3 to Travis CI versions
-rw-r--r--.travis.yml2
-rw-r--r--setup.py3
2 files changed, 4 insertions, 1 deletions
diff --git a/.travis.yml b/.travis.yml
index 5f8d0a9..d5729e2 100644
--- a/.travis.yml
+++ b/.travis.yml
@@ -7,6 +7,8 @@ matrix:
- python: 3.5
- python: 3.6
- python: 3.7
+ - python: 3.8-dev
+ - python: pypy3
dist: xenial
sudo: true
fast_finish: true
diff --git a/setup.py b/setup.py
index 0dae3ce..50435e5 100644
--- a/setup.py
+++ b/setup.py
@@ -3,7 +3,7 @@
"""Setup script for the pyparsing module distribution."""
from setuptools import setup
-from pyparsing import __version__ as pyparsing_version
+from pyparsing import __version__ as pyparsing_version, __doc__ as pyparsing_description
modules = ["pyparsing",]
@@ -11,6 +11,7 @@ setup(# Distribution meta-data
name = "pyparsing",
version = pyparsing_version,
description = "Python parsing module",
+ long_description = pyparsing_description,
author = "Paul McGuire",
author_email = "ptmcg@users.sourceforge.net",
url = "https://github.com/pyparsing/pyparsing/",