summaryrefslogtreecommitdiff
path: root/.gitignore
diff options
context:
space:
mode:
authorIvan Kanakarakis <ivan.kanak@gmail.com>2018-06-29 19:33:49 +0300
committerIvan Kanakarakis <ivan.kanak@gmail.com>2018-06-29 19:38:33 +0300
commit24dedf1450fd3631fc3dc40e531bc7a6fdbce3a0 (patch)
treedb59a32802afdd7730e9b8153abf7bdc805f99ad /.gitignore
parent65f8e4c4d4c6673db678882ec80deb0967c22092 (diff)
downloadpysaml2-24dedf1450fd3631fc3dc40e531bc7a6fdbce3a0.tar.gz
Update gitignore file
Signed-off-by: Ivan Kanakarakis <ivan.kanak@gmail.com>
Diffstat (limited to '.gitignore')
-rw-r--r--.gitignore312
1 files changed, 149 insertions, 163 deletions
diff --git a/.gitignore b/.gitignore
index cd88f97f..2bc235e7 100644
--- a/.gitignore
+++ b/.gitignore
@@ -1,205 +1,191 @@
-*.pyc
-*.~
-\#*
-.*~
-.eggs
-*.egg
-*.egg-info
-example/*/*.log
-example/*.db
-example/*/*.db
-tests/*.db
-tests/*.log
-build/
-dist/
-example/sp/identities
-subject.db
-.idea
-.project
-.pydevproject
-.DS_store
-.gitignore
-debug_*
-*.log
-*.out
-tmp*
-*.tmp
-*.log.*
-*.db
-*egg-info*
-.coverage
-*.tmpl
-*.iml
-_build/
-.cache
-*.swp
-.tox
-env
-bin/
-include/
-lib/
-local/
-pip-selfcheck.json
-
-example/idp3/htdocs/login.mako
-
-example/idp3/idp.py
-
-example/idp3/idp.xml
-
-example/idp3/idp_conf.py
-
-example/idp3/idp_err.xml
-
-example/idp3/idp_user.py
-
-example/idp3/metadata.xml
-
-example/idp3/modules/login.mako.py
-
-example/idp3/modules/root.mako.py
-
-example/idp3/pki/create_key.sh
-
-example/idp3/pki/mycert.pem
-
-example/idp3/pki/mykey.pem
-
-example/idp3/templates/root.mako
-
-example/sp2/attributemaps/basic.py
-
-example/sp2/attributemaps/saml_uri.py
-
-example/sp2/attributemaps/shibboleth_uri.py
-
-example/sp2/pki/mycert.pem
-
-example/sp2/pki/mykey.pem
-
-example/sp2/sp.py
-
-example/sp2/sp.xml
+### Custom.gitignore
-example/sp2/sp_conf.py
+example/*/*.xml
+example/*/*_conf.py
+example/*/modules/
-example/sp2/who.ini
-
-example/idp2/idp.xml
-
-example/idp2/idp_conf_test.py
-
-example/idp2/metadata.xml
-
-example/idp2/modules/login.mako.py
-
-example/idp2/modules/root.mako.py
-
-example/idp3/idp_conf_test.py
-
-update
-
-src/saml2/entity_category/swamid2.py
-
-example/idp2/IdpTestConf.py
-
-example/idp2/create_idp_conf.json
-
-example/idp2/create_idp_conf.py
-
-example/idp2/idpSaml2test.xml
-
-example/idp2/idp_conf.template
-
-example/idp2/idp_conf_saml2test.py
-
-example/sp/sp.xml
-
-example/idp2/idp_conf_local.py
-
-example/sp/sp_conf_local.py
-
-example/sp/my_backup_sp_conf_local.py
-
-example/sp/backup_sp_conf_local.py
+tests/*.log.*
+tests/*.db
-example/idp2/pki/localhost.ca.crt
+eptid
-example/idp2/pki/localhost.ca.crt
-example/idp2/pki/localhost.ca.key
+### Python.gitignore
+### https://github.com/github/gitignore/blob/master/Python.gitignore
-example/idp2/pki/localhost.ca.key
+# Byte-compiled / optimized / DLL files
+__pycache__/
+*.py[cod]
+*$py.class
-example/sp/pki/localhost.ca.crt
+# C extensions
+*.so
-example/sp/pki/localhost.ca.crt
+# Distribution / packaging
+.Python
+build/
+develop-eggs/
+dist/
+downloads/
+eggs/
+.eggs/
+lib/
+lib64/
+parts/
+sdist/
+var/
+wheels/
+*.egg-info/
+.installed.cfg
+*.egg
+MANIFEST
+
+# PyInstaller
+#
+# Usually these files are written by a python script from a template before
+# PyInstaller builds the exe, so as to inject date/other infos into it.
+*.manifest
+*.spec
+
+# Installer logs
+pip-log.txt
+pip-delete-this-directory.txt
+
+# Unit test / coverage reports
+htmlcov/
+.tox/
+.coverage
+.coverage.*
+.cache
+nosetests.xml
+coverage.xml
+*.cover
+.hypothesis/
+.pytest_cache/
-example/sp/pki/localhost.ca.key
+# Translations
+*.mo
+*.pot
-example/sp/pki/localhost.ca.key
+# Django stuff:
+*.log
+local_settings.py
+db.sqlite3
-example/idp2/idp_conf_dirgweb.py
+# Flask stuff:
+instance/
+.webassets-cache
-example/idp2/idp_conf_nocert.py
+# Scrapy stuff:
+.scrapy
-example/idp2/idp_conf_proxy.py
+# Sphinx documentation
+docs/_build/
-example/idp2/idp_nocert.xml
+# PyBuilder
+target/
-example/sp/nocert_sp_conf/sp_nocert.xml
+# Jupyter Notebook
+.ipynb_checkpoints
-example/sp/normal_sp_conf/sp.xml
+# pyenv
+.python-version
-example/sp/normal_sp_conf/sp_conf.py
+# celery beat schedule file
+celerybeat-schedule
-example/sp/normal_sp_conf/who.ini
+# SageMath parsed files
+*.sage.py
-example/sp/sp_nocert.xml
+# Environments
+.env
+.venv
+env/
+venv/
+ENV/
+env.bak/
+venv.bak/
-example/sp/sp_nocert2.xml
+# Spyder project settings
+.spyderproject
+.spyproject
-example/sp/test.py
+# Rope project settings
+.ropeproject
-example/sp/sp_conf.py
+# mkdocs documentation
+/site
-example/sp/nocert_sp_conf/sp.xml
+# mypy
+.mypy_cache/
-example/sp/nocert_sp_conf/sp_conf.py
-example/sp/nocert_sp_conf/who.ini
+### Linux.gitignore
+### https://github.com/github/gitignore/blob/master/Global/Linux.gitignore
-example/sp-repoze/my_sp.xml
+*~
-example/sp-repoze/pki/localhost.ca.crt
+# temporary files which can be created if a process still has a handle open of a deleted file
+.fuse_hidden*
-example/sp-repoze/pki/localhost.ca.key
+# KDE directory preferences
+.directory
-example/sp-repoze/sp.xml
+# Linux trash folder which might appear on any partition or disk
+.Trash-*
-example/sp-repoze/sp.xml
+# .nfs files are created when an open file is removed but is still being accessed
+.nfs*
-example/sp-repoze/sp_conf.py
-example/sp-repoze/sp_conf.py
+### masOS.gitignore
+### https://github.com/github/gitignore/blob/master/Global/macOS.gitignore
-example/idp2/sp_test.xml
+# General
+.DS_Store
+.AppleDouble
+.LSOverride
-example/sp-repoze/idp_test.xml
+# Icon must end with two \r
+Icon
-example/sp-repoze/sp_conf_example.py
+# Thumbnails
+._*
-example/idp2/idp_conf_example.py
+# Files that might appear in the root of a volume
+.DocumentRevisions-V100
+.fseventsd
+.Spotlight-V100
+.TemporaryItems
+.Trashes
+.VolumeIcon.icns
+.com.apple.timemachine.donotpresent
-example/idp2/lidp.xml
+# Directories potentially created on remote AFP share
+.AppleDB
+.AppleDesktop
+Network Trash Folder
+Temporary Items
+.apdisk
-example/idp2/old_idp.xml
-example/sp-repoze/old_sp.xml
+### Vim.gitignore
+### https://github.com/github/gitignore/blob/master/Global/Vim.gitignore
-example/sp-repoze/sp_conf_2.Pygmalion
+# Swap
+[._]*.s[a-v][a-z]
+[._]*.sw[a-p]
+[._]s[a-rt-v][a-z]
+[._]ss[a-gi-z]
+[._]sw[a-p]
-example/sp-repoze/sp_conf_2.py
+# Session
+Session.vim
-sp.xml
-tests/pki/qwerty.*
+# Temporary
+.netrwhist
+*~
+# Auto-generated tag files
+tags
+# Persistent undo
+[._]*.un~