summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRoland Hedberg <roland.hedberg@adm.umu.se>2015-04-01 17:13:56 +0200
committerRoland Hedberg <roland.hedberg@adm.umu.se>2015-04-01 17:13:56 +0200
commitd38e94715be08e838e0c9c51676604d1c82669d7 (patch)
treee29fe6b155004b4c7682a3225439e48ea82beb17
parent89a52d442229ab2b3f80a4b6bf69c70c289db71b (diff)
parentd55bfeebe70102278181de9d6bca8b44deb9a1aa (diff)
downloadpysaml2-d38e94715be08e838e0c9c51676604d1c82669d7.tar.gz
Merge pull request #200 from shabda/master
Linked various documentation files and fixed some settings for readthedocs
-rw-r--r--.gitignore1
-rw-r--r--README45
-rw-r--r--doc/conf.py7
-rw-r--r--doc/contents.rst16
-rw-r--r--doc/index.rst50
-rw-r--r--doc/metadata.rst18
6 files changed, 44 insertions, 93 deletions
diff --git a/.gitignore b/.gitignore
index f6d10588..fe1282ad 100644
--- a/.gitignore
+++ b/.gitignore
@@ -27,6 +27,7 @@ tmp*
*egg-info*
.coverage
*.tmpl
+_build/
example/idp3/htdocs/login.mako
diff --git a/README b/README
deleted file mode 100644
index 61b9615a..00000000
--- a/README
+++ /dev/null
@@ -1,45 +0,0 @@
-README for PySAML2
-==================
-
-Dependencies
-------------
-PySAML2 should be compatible with any python >= 2.6 not 3.X yet.
-
-Install
--------
-You will need xmlsec1 to be able to sign/verify, encrypt/decrypt.
-You can find xmlsec1 here:
-
- http://www.aleksey.com/xmlsec/
-
-Apart from that a normal
-
- python setup.py install
-
-will install the package.
-
-Documentation
--------------
-Look in the doc/ subdirectory.
-
-Comments, support, bug reports
-------------------------------
-
-Project page on :
-
-https://github.com/rohe/pysaml2
-
-Use the Pysaml2@uma.es mailing list. Bug reports can either be emailed
-to this mailing list of added to the github repository
-https://github.com/rohe/pysaml2.
-
-You can subscribe to this mailing list at
-http://delfos.sci.uma.es/mailman/listinfo/pysaml2
-
-Archives are available at
-http://delfos.sci.uma.es/mailman/private/pysaml2/
-
-Contributors
-------------
-* Roland Hedberg: main author / maintainer
-* Lorenzo Gil Sanchez: Django integration
diff --git a/doc/conf.py b/doc/conf.py
index 8397b3d7..3e43897f 100644
--- a/doc/conf.py
+++ b/doc/conf.py
@@ -91,7 +91,12 @@ pygments_style = 'sphinx'
# The theme to use for HTML and HTML Help pages. Major themes that come with
# Sphinx are currently 'default' and 'sphinxdoc'.
-html_theme = 'default'
+html_theme = 'alabaster'
+on_rtd = os.environ.get('READTHEDOCS', None) == 'True'
+
+if on_rtd: # only import and set the theme if we're building docs locally
+ html_theme = 'sphinx_rtd_theme'
+
# Theme options are theme-specific and customize the look and feel of a theme
# further. For a list of options available for each theme, see the
diff --git a/doc/contents.rst b/doc/contents.rst
deleted file mode 100644
index 39984b51..00000000
--- a/doc/contents.rst
+++ /dev/null
@@ -1,16 +0,0 @@
-Contents
-========
-
-* :ref:`genindex`
-* :ref:`modindex`
-* :ref:`search`
-
-.. toctree::
- :maxdepth: 4
-
- code/s2repoze
- code/saml2
- code/xmldsig
- code/xmlenc
-
-
diff --git a/doc/index.rst b/doc/index.rst
index e9447c68..4b596290 100644
--- a/doc/index.rst
+++ b/doc/index.rst
@@ -1,20 +1,33 @@
-.. _howto:
+:Release: |release|
+:Date: |today|
+
+About SAML 2.0
+==============
+
+SAML 2.0 or Security Assertion Markup Language 2.0 is a version of the SAML standard for exchanging authentication and authorization data between security domains.
+
+About PySAML2
+=============
+
+PySAML2 is a pure python implementation of SAML2. It contains all
+necessary pieces for building a SAML2 service provider or an identity provider.
+The distribution contains examples of both.
+Originally written to work in a WSGI environment there are extensions that
+allow you to use it with other frameworks.
+
How to use PySAML2
===================
-:Release: |release|
-:Date: |today|
-
-Before you can use Pysaml2, you'll need to get it installed.
+Before you can use Pysaml2, you'll need to get it installed.
If you have not done it yet, read the :ref:`install`
Well, now you have it installed and you want to do something.
-And I'm sorry to tell you this; but there isn't really a lot you can do with
+And I'm sorry to tell you this; but there isn't really a lot you can do with
this code on it's own.
-Sure you can send a AuthenticationRequest to an IdentityProvider or a
+Sure you can send a AuthenticationRequest to an IdentityProvider or a
AttributeQuery to an AttributeAuthority but in order to get what they
return you have to sit behind a Web server. Well that is not really true since
the AttributeQuery would be over SOAP and you would get the result over the
@@ -22,19 +35,30 @@ connection you have to the AttributeAuthority.
But anyway, you may get my point. This is middleware stuff !
-PySAML2 is built to fit into a
+PySAML2 is built to fit into a
`WSGI <http://www.python.org/dev/peps/pep-0333/>`_ application
-But it can be used in a non-WSGI environment too.
+But it can be used in a non-WSGI environment too.
So you will find descriptions of both cases here.
-The configuration is the same disregarding whether you are using PySAML2 in a
+The configuration is the same disregarding whether you are using PySAML2 in a
WSGI or non-WSGI environment.
+Table of contents
+==================
+
.. toctree::
- :maxdepth: 1
+ :maxdepth: 2
+
+ install
+ examples/index
+ howto/index
+ sp_test/internal
+
+
- config
+* :ref:`genindex`
+* :ref:`modindex`
+* :ref:`search`
-
diff --git a/doc/metadata.rst b/doc/metadata.rst
deleted file mode 100644
index 1c9d48b3..00000000
--- a/doc/metadata.rst
+++ /dev/null
@@ -1,18 +0,0 @@
-.. _metadata:
-
-***************************************************
-Base classes representing Saml2.0 MetaData elements
-***************************************************
-
-:Author: Roland Hedberg
-:Version: |version|
-
-.. module:: MetaData
- :synopsis: Base classes representing Saml2.0 metadata elements.
-
-Module
-==========
-
-.. automodule:: saml2.metadata
- :members:
-