summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIvan Kanakarakis <ivan.kanak@gmail.com>2018-08-07 21:02:16 +0300
committerIvan Kanakarakis <ivan.kanak@gmail.com>2018-08-07 21:02:16 +0300
commita17f233c7a845105913ee4c72c33eb6c60a6d5c6 (patch)
tree92b144394d8f6deb34979ef77309c073c016a5d6
parentcf144871dc8d457d4bbc04e0b019bc937be4e9de (diff)
downloadpysaml2-a17f233c7a845105913ee4c72c33eb6c60a6d5c6.tar.gz
Release 4.6.0v4.6.0
Signed-off-by: Ivan Kanakarakis <ivan.kanak@gmail.com>
-rw-r--r--CHANGELOG.rst41
-rw-r--r--VERSION2
2 files changed, 42 insertions, 1 deletions
diff --git a/CHANGELOG.rst b/CHANGELOG.rst
index eb37ed2b..901af39f 100644
--- a/CHANGELOG.rst
+++ b/CHANGELOG.rst
@@ -1,6 +1,47 @@
Changelog
=========
+4.6.0 (2018-08-07)
+------------------
+
+- Allow configuration and specification of id attribute name
+- Retrieve SLO endpoint by the appropriate service type
+- Deprecate AESCipher and aes.py module
+- Add saml2.cryptography module
+- Always generate a random IV for AES operations / Address CVE-2017-1000246
+- Remove unused and broken RSA code
+- Add more nameid-format definitions
+- Remove invalid nameid-format
+- Retrieve pacakge version from pkg_resources
+- Fully replace Cryptodome library with cryptography
+- Fix SSRF caused by URI attribute of Reference element
+- Omit relay state in HTTP-POST response when empty
+- Fix eidas natural person attribute URIs
+- Add eidas attributes for legal person to saml2_uri attributemap
+- Fix deprecation and resource warnings.
+- Fix date format to show month, not minutes
+- Fix typos
+- s2repoze: Define session_info variable before use
+- s2repoze: Correctly pull the SAMLRequest from Redirect LogoutRequests
+- s2repoze: Include SCRIPT_NAME when checking whether current URL is a logout endpoint
+- tests: Document and test all supported Python versions
+- tests: Generate and upload coverage reports to codecov
+- tests: Include dependencies information in test report
+- tests: Run tests in verbose mode
+- tests: Clean up unclosed files causing ResourceWarnings
+- build: Set minimal version for cryptography package
+- build: Set the correct version in the docs
+- build: Update build manifest to include the correct files
+- build: Switch from setup.py to setup.cfg
+- docs: Add editorconfig file with basic rules
+- docs: Update gitignore file
+- docs: Remove downloads badge as it is no longer available
+- docs: Update all pypi.python.org URLs to pypi.org
+- docs: Updated license and renamed the file.
+- examples: Do not request a signed response - backwards compatibility
+- examples: Fix wsgiserver usage for example sp
+- examples: Fix cherrypy.wsgiserver usage
+
0.4.2 (2012-03-27)
------------------
- Add default attribute mappings
diff --git a/VERSION b/VERSION
index a84947d6..6016e8ad 100644
--- a/VERSION
+++ b/VERSION
@@ -1 +1 @@
-4.5.0
+4.6.0