summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIvan Kanakarakis <ivan.kanak@gmail.com>2019-07-09 11:20:09 +0300
committerIvan Kanakarakis <ivan.kanak@gmail.com>2019-07-09 11:40:05 +0300
commit8d45679ad6605c28a13c7f17b408ab03bf91ad2a (patch)
tree0fa888a23021cd36b8b9ea7b10838d3bbbabd60c
parent58138e05c42ab749b1f44c6e48715c92ca79cb5f (diff)
downloadpysaml2-8d45679ad6605c28a13c7f17b408ab03bf91ad2a.tar.gz
Update release instructions to mention release branch creation
Signed-off-by: Ivan Kanakarakis <ivan.kanak@gmail.com>
-rw-r--r--release-howto.rst26
1 files changed, 15 insertions, 11 deletions
diff --git a/release-howto.rst b/release-howto.rst
index 6c6dbc29..1ea60ba9 100644
--- a/release-howto.rst
+++ b/release-howto.rst
@@ -20,19 +20,26 @@ When releasing a new version, the following steps should be taken:
the long description nicely. It will treat it as plain text instead.
3. Update the version in the VERSION_ file and report the changes in
- CHANGELOG.rst_ and commit the changes.::
+ CHANGELOG.md_ and commit the changes.::
+ git add CHANGELOG.md
+ git add VERSION
git commit -v -s -m "Release version X.Y.Z"
-4. Create a release tag_::
+4. Create a release branch_::
+
+ git branch vX.Y.Z
+
+5. Create a release tag_::
git tag -a -s vX.Y.Z -m "Version X.Y.Z"
-5. Push these changes to Github::
+6. Push these changes to Github::
git push --follow-tags origin vX.Y.Z
+ git push --follow-tags origin vX.Y.Z:vX.Y.Z
-6. Create a source and wheel distribution and upload it to PyPI::
+7. Create a source and wheel distribution and upload it to PyPI::
# generate a source and wheel distribution at once
python setup.py sdist bdist_wheel
@@ -46,7 +53,7 @@ When releasing a new version, the following steps should be taken:
# then, upload release on official pypi.org
twine upload dist/pysaml2-X.Y.Z*
-7. Upload the documentation to PyPI. First you need to generate the html
+8. Upload the documentation to PyPI. First you need to generate the html
version of the documentation::
cd docs/
@@ -57,7 +64,7 @@ When releasing a new version, the following steps should be taken:
Submit the generated pysaml2-docs.zip file.
-8. Send an email to the pysaml2 list announcing this release
+9. Send an email to the pysaml2 list announcing this release
**Important:** Once released to PyPI or any other public download location,
@@ -66,11 +73,8 @@ release ("brown bag release"). In such a case it should simply be superseded
immediately by a new, improved release.
-This document is based on zope release-software_ guidelines.
-
-
.. _VERSION: https://github.com/IdentityPython/pysaml2/blob/master/VERSION
-.. _CHANGELOG.rst: https://github.com/IdentityPython/pysaml2/blob/master/CHANGELOG.rst
+.. _CHANGELOG.md: https://github.com/IdentityPython/pysaml2/blob/master/CHANGELOG.md
.. _docutils: http://docutils.sourceforge.net/
+.. _branch: https://git-scm.com/book/en/v2/Git-Branching-Branches-in-a-Nutshell
.. _tag: https://git-scm.com/book/en/v2/Git-Basics-Tagging#_annotated_tags
-.. _release-software: https://zopetoolkit.readthedocs.io/en/latest/process/releasing-software.html