summaryrefslogtreecommitdiff
path: root/release-howto.rst
diff options
context:
space:
mode:
authorIvan Kanakarakis <ivan.kanak@gmail.com>2018-08-30 00:28:11 +0300
committerIvan Kanakarakis <ivan.kanak@gmail.com>2018-08-30 00:28:11 +0300
commite2675f73d890b72316ae884d2b14354643f390c9 (patch)
treecd72077c20eca9cdf1145f643f52624f4a9d46cf /release-howto.rst
parentb8c84ec07fe825d5a49e3b6a3751a8ce4dd1140d (diff)
downloadpysaml2-e2675f73d890b72316ae884d2b14354643f390c9.tar.gz
Update release instructions
Signed-off-by: Ivan Kanakarakis <ivan.kanak@gmail.com>
Diffstat (limited to 'release-howto.rst')
-rw-r--r--release-howto.rst26
1 files changed, 20 insertions, 6 deletions
diff --git a/release-howto.rst b/release-howto.rst
index f6fa97a1..17ce0133 100644
--- a/release-howto.rst
+++ b/release-howto.rst
@@ -22,20 +22,32 @@ When releasing a new version, the following steps should be taken:
If this will produce warning or errors, PyPI will be unable to render
the long description nicely. It will treat it as plain text instead.
-4. Update the version in the VERSION_ file and commit the change.
+4. Update the version in the VERSION_ file and report the changes in
+ CHANGELOG.rst_ and commit the changes.::
+
+ git commit -v -s -m "Release version X.Y.Z"
5. Create a release tag_::
- git tag -a vX.Y.Z -m "Release of version X.Y.Z"
+ git tag -a -s vX.Y.Z -m "Version X.Y.Z"
6. Push these changes to Github::
- git push origin vX.Y.Z
+ git push --follow-tags origin vX.Y.Z
+
+7. Create a source and wheel distribution and upload it to PyPI::
+
+ # generate a source and wheel distribution at once
+ python setup.py sdist bdist_wheel
+
+ # generated files are under dist/
+ ls dist/
-7. Create a source distribution and upload it to PyPI using the following
- command::
+ # upload release on test.pypi.org
+ twine upload --repository-url https://test.pypi.org/legacy/ dist/pysaml2-X.Y.Z*
- python setup.py register sdist upload
+ # then, upload release on official pypi.org
+ twine upload dist/pysaml2-X.Y.Z*
8. Upload the documentation to PyPI. First you need to generate the html
version of the documentation::
@@ -60,6 +72,8 @@ immediately by a new, improved release.
This document is based on zope release-software_ guidelines.
+.. _VERSION: https://github.com/IdentityPython/pysaml2/blob/master/VERSION
+.. _CHANGELOG.rst: https://github.com/IdentityPython/pysaml2/blob/master/CHANGELOG.rst
.. _docutils: http://docutils.sourceforge.net/
.. _tag: https://git-scm.com/book/en/v2/Git-Basics-Tagging#_annotated_tags
.. _release-software: https://zopetoolkit.readthedocs.io/en/latest/process/releasing-software.html