summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorClint Byrum <clint@fewbar.com>2015-05-15 11:40:37 -0700
committerClint Byrum <clint@fewbar.com>2015-05-15 11:52:15 -0700
commit45f88c16268ccf8a6c106b1ea20e84515c74e476 (patch)
tree3adf708b1898965a5963cb9e5ced6ce2447c6977 /setup.py
parent2b86176aafbf93c3492476069a19ee3841d562aa (diff)
downloadpysaml2-45f88c16268ccf8a6c106b1ea20e84515c74e476.tar.gz
Use six.string_types instead of basestring
In python3 strings are different, so basestring isn't available anymore. While examining these uses, all of them still work fine with six.string_types and should not need any new special handling to deal with bytes.
Diffstat (limited to 'setup.py')
-rwxr-xr-xsetup.py3
1 files changed, 2 insertions, 1 deletions
diff --git a/setup.py b/setup.py
index 97bc582d..25006c80 100755
--- a/setup.py
+++ b/setup.py
@@ -31,7 +31,8 @@ install_requires = [
'pytz',
'pyOpenSSL',
'python-dateutil',
- 'argparse'
+ 'argparse',
+ 'six'
]
tests_require = [