summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorRoland Hedberg <roland.hedberg@adm.umu.se>2014-10-26 16:42:03 -0400
committerRoland Hedberg <roland.hedberg@adm.umu.se>2014-10-26 16:42:03 -0400
commita714765c9ea2e48b3cfb8ba29c9c195cdd11a1c4 (patch)
tree0e061f9826fef46ddd09ed2ddb5a813dcbe07009 /setup.py
parentc04ba6575a998e7ef8dfb60d65b333524ff0bd59 (diff)
parent3c3ed2f1eb43fbb709b68261e6d5543faf38a97e (diff)
downloadpysaml2-a714765c9ea2e48b3cfb8ba29c9c195cdd11a1c4.tar.gz
Merge branch 'master' of https://github.com/rhoerbe/saml2test
Conflicts: INSTALL LICENSE.txt README.rst doc/Makefile doc/conf.py doc/index.rst doc/install.rst doc/make.bat doc/make.sh setup.py tests/attributemaps/basic.py tests/attributemaps/saml_uri.py tests/attributemaps/shibboleth_uri.py
Diffstat (limited to 'setup.py')
-rwxr-xr-xsetup.py113
1 files changed, 35 insertions, 78 deletions
diff --git a/setup.py b/setup.py
index 135f7791..da929477 100755
--- a/setup.py
+++ b/setup.py
@@ -1,85 +1,42 @@
-#!/usr/bin/env python
-
-import sys
+#!/usr/bin/python
+#
+# Copyright (C) 2013 Umea Universitet, Sweden
+#
+# Licensed under the Apache License, Version 2.0 (the "License");
+# you may not use this file except in compliance with the License.
+# You may obtain a copy of the License at
+#
+# http://www.apache.org/licenses/LICENSE-2.0
+#
+# Unless required by applicable law or agreed to in writing, software
+# distributed under the License is distributed on an "AS IS" BASIS,
+# WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or implied.
+# See the License for the specific language governing permissions and
+# limitations under the License.
+#
from setuptools import setup
-from setuptools.command.test import test as TestCommand
-
-class PyTest(TestCommand):
-
- def finalize_options(self):
- TestCommand.finalize_options(self)
- self.test_args = []
- self.test_suite = True
-
- def run_tests(self):
- #import here, cause outside the eggs aren't loaded
- import pytest
- errno = pytest.main(self.test_args)
- sys.exit(errno)
-
-
-install_requires = [
- # core dependencies
- 'decorator',
- 'requests >= 1.0.0',
- 'paste',
- 'zope.interface',
- 'repoze.who',
- 'pycrypto', # 'Crypto'
- 'pytz',
- 'pyOpenSSL',
- 'python-dateutil',
- 'argparse'
-]
-tests_require = [
- 'mongodict',
- 'pyasn1',
- 'pymongo',
- 'python-memcached == 1.51',
- 'pytest',
- 'mako',
- #'pytest-coverage',
-]
-
-
-# only for Python 2.6
-if sys.version_info < (2, 7):
- install_requires.append('importlib')
+__author__ = 'rohe0002'
setup(
- name='pysaml2',
- version='2.1.0',
- description='Python implementation of SAML Version 2 to be used in a WSGI environment',
- # long_description = read("README"),
- author='Roland Hedberg',
- author_email='roland.hedberg@adm.umu.se',
- license='Apache 2.0',
- url='https://github.com/rohe/pysaml2',
-
- packages=['saml2', 'xmldsig', 'xmlenc', 's2repoze', 's2repoze.plugins',
- "saml2/profile", "saml2/schema", "saml2/extension",
- "saml2/attributemaps", "saml2/authn_context",
- "saml2/entity_category", "saml2/userinfo"],
-
- package_dir={'': 'src'},
- package_data={'': ['xml/*.xml']},
- classifiers=["Development Status :: 4 - Beta",
+ name="saml2test",
+ version="0.4.3",
+ description="SAML2 test tool",
+ author = "Roland Hedberg",
+ author_email = "roland.hedberg@adm.umu.se",
+ license="Apache 2.0",
+ packages=["idp_test", "idp_test/package", "saml2test", "sp_test", "utility"],
+ package_dir = {"": "src"},
+ classifiers = [
+ "Development Status :: 4 - Beta",
"License :: OSI Approved :: Apache Software License",
- "Topic :: Software Development :: Libraries :: Python Modules",
- "Programming Language :: Python :: 2.6",
- "Programming Language :: Python :: 2.7"],
-
- scripts=["tools/parse_xsd2.py", "tools/make_metadata.py",
- "tools/mdexport.py", "tools/merge_metadata.py"],
-
- tests_require=tests_require,
- extras_require={
- 'testing': tests_require,
- },
- install_requires=install_requires,
+ "Topic :: Software Development :: Libraries :: Python Modules"],
+ install_requires = ["pysaml2",
+ "mechanize",
+ "argparse",
+ "beautifulsoup4",
+ "mako"],
zip_safe=False,
- test_suite='tests',
- cmdclass={'test': PyTest},
-)
+ scripts=["script/idp_testdrv.py", "script/sp_testdrv.py"]
+ ) \ No newline at end of file