summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorJon Dufresne <jon.dufresne@gmail.com>2017-10-03 22:12:59 -0700
committerIvan Kanakarakis <ivan.kanak@gmail.com>2018-06-28 21:53:34 +0300
commit0408eea42754c37d1fef6894aa350fddc8afd81f (patch)
treea21597c27ebe85a6c58738a6fffb22b224aebbf6 /setup.py
parentf22506ed9ffb737e6e26942fa5d3f3ba851c0a87 (diff)
downloadpysaml2-0408eea42754c37d1fef6894aa350fddc8afd81f.tar.gz
Document and test all supported Python versions
Added trove classifiers for all supported Python versions. Added missing versions to tox and Travis CI configurations. Use tox-travis to kick of tox from Travis. Ensures library is tested against all modern Python versions to reduce the risk of regressions.
Diffstat (limited to 'setup.py')
-rwxr-xr-xsetup.py4
1 files changed, 4 insertions, 0 deletions
diff --git a/setup.py b/setup.py
index f653ec50..23ac065c 100755
--- a/setup.py
+++ b/setup.py
@@ -52,9 +52,13 @@ setup(
"Development Status :: 4 - Beta",
"License :: OSI Approved :: Apache Software License",
"Topic :: Software Development :: Libraries :: Python Modules",
+ "Programming Language :: Python",
+ "Programming Language :: Python :: 2",
"Programming Language :: Python :: 2.7",
+ "Programming Language :: Python :: 3",
"Programming Language :: Python :: 3.4",
"Programming Language :: Python :: 3.5"
+ "Programming Language :: Python :: 3.6"
],
scripts=["tools/parse_xsd2.py", "tools/make_metadata.py",