summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorJuri Hudolejev <jhudolejev@gmail.com>2015-06-24 15:30:01 +0400
committerJuri Hudolejev <jhudolejev@gmail.com>2015-06-24 15:32:09 +0400
commit5e27e077455418374dcfcd18efe8b21b1c14f514 (patch)
treeaca1f1d7bb9309103404a2afc01f72199a986a67 /setup.py
parent40603ae82e19c47a4e725320b709b03f92810875 (diff)
downloadpysaml2-5e27e077455418374dcfcd18efe8b21b1c14f514.tar.gz
Remove argparse from install_requires for Python 2.7
argparse is part of Python 2.7: https://docs.python.org/2.7/library/argparse.html
Diffstat (limited to 'setup.py')
-rwxr-xr-xsetup.py2
1 files changed, 1 insertions, 1 deletions
diff --git a/setup.py b/setup.py
index 7f8f1895..c5a28a7e 100755
--- a/setup.py
+++ b/setup.py
@@ -31,7 +31,6 @@ install_requires = [
'pytz',
'pyOpenSSL',
'python-dateutil',
- 'argparse',
'six'
]
@@ -49,6 +48,7 @@ tests_require = [
# only for Python 2.6
if sys.version_info < (2, 7):
+ install_requires.append('argparse')
install_requires.append('importlib')
setup(