summaryrefslogtreecommitdiff
path: root/src/saml2/entity.py
diff options
context:
space:
mode:
authorHans Hörberg <hans.horberg@umu.se>2015-11-19 10:48:35 +0100
committerHans Hörberg <hans.horberg@umu.se>2015-11-19 10:48:35 +0100
commit4935c66941a0aaed3ad3b4577e4a046910bcbd7d (patch)
tree5a6f44eec093e3a1a555f8df6b5a74ff88e84c41 /src/saml2/entity.py
parent361b29f4641c2e75d7a522990e0e5789e488c3c0 (diff)
parent2ce425c84ceb2f37e8cf9f2eb383abdbc1a2f087 (diff)
downloadpysaml2-4935c66941a0aaed3ad3b4577e4a046910bcbd7d.tar.gz
Merge remote-tracking branch 'upstream/master'
# Conflicts: # setup.py # src/saml2/server.py
Diffstat (limited to 'src/saml2/entity.py')
-rw-r--r--src/saml2/entity.py8
1 files changed, 7 insertions, 1 deletions
diff --git a/src/saml2/entity.py b/src/saml2/entity.py
index 4b3bdca4..b5fcb3d2 100644
--- a/src/saml2/entity.py
+++ b/src/saml2/entity.py
@@ -215,10 +215,16 @@ class Entity(HTTPBase):
if binding == BINDING_HTTP_POST:
logger.info("HTTP POST")
+ # if self.entity_type == 'sp':
+ # info = self.use_http_post(msg_str, destination, relay_state,
+ # typ)
+ # info["url"] = destination
+ # info["method"] = "POST"
+ # else:
info = self.use_http_form_post(msg_str, destination,
relay_state, typ)
info["url"] = destination
- info["method"] = "GET"
+ info["method"] = "POST"
elif binding == BINDING_HTTP_REDIRECT:
logger.info("HTTP REDIRECT")
info = self.use_http_get(msg_str, destination, relay_state, typ,