summaryrefslogtreecommitdiff
path: root/tests/idp_sp_conf.py
diff options
context:
space:
mode:
authorLorenzo Gil Sanchez <lorenzo.gil.sanchez@gmail.com>2013-04-02 17:07:54 +0200
committerLorenzo Gil Sanchez <lorenzo.gil.sanchez@gmail.com>2013-04-02 17:07:54 +0200
commit2ae12290b0cffe61e981f1ce94d5187f5d66aef8 (patch)
treec2b61e735f185c29f8f9474942654f1195279094 /tests/idp_sp_conf.py
parentca6afd92fc6730ba17a78de6cb0cef808a8d6d18 (diff)
downloadpysaml2-2ae12290b0cffe61e981f1ce94d5187f5d66aef8.tar.gz
Allow running the tests from the pysaml2 root directory.
This improves previous work for running the tests via the command "python setup.py test" from a fresh clone. This can be very useful to integrate pysaml2 in a continuous integration system such as Jenkins or Travis.
Diffstat (limited to 'tests/idp_sp_conf.py')
-rw-r--r--tests/idp_sp_conf.py16
1 files changed, 6 insertions, 10 deletions
diff --git a/tests/idp_sp_conf.py b/tests/idp_sp_conf.py
index d8dee282..e4da5e68 100644
--- a/tests/idp_sp_conf.py
+++ b/tests/idp_sp_conf.py
@@ -6,11 +6,7 @@ from saml2.saml import NAME_FORMAT_URI
BASE = "http://localhost:8088/"
-try:
- from saml2.sigver import get_xmlsec_binary
- xmlsec_path = get_xmlsec_binary(["/opt/local/bin"])
-except ImportError:
- xmlsec_path = '/usr/bin/xmlsec1'
+from pathutils import full_path, xmlsec_path
CONFIG = {
"entityid" : "urn:mace:example.com:saml:roland:idp",
@@ -39,7 +35,7 @@ CONFIG = {
# }
}
},
- "subject_data": "subject_data.db",
+ "subject_data": full_path("subject_data.db"),
},
"sp": {
"endpoints":{
@@ -51,13 +47,13 @@ CONFIG = {
}
},
"debug" : 1,
- "key_file" : "test.key",
- "cert_file" : "test.pem",
+ "key_file" : full_path("test.key"),
+ "cert_file" : full_path("test.pem"),
"xmlsec_binary" : xmlsec_path,
"metadata": {
- "local": ["metadata.xml", "vo_metadata.xml"],
+ "local": [full_path("metadata.xml"), full_path("vo_metadata.xml")],
},
- "attribute_map_dir" : "attributemaps",
+ "attribute_map_dir" : full_path("attributemaps"),
"organization": {
"name": "Exempel AB",
"display_name": [("Exempel AB","se"),("Example Co.","en")],