summaryrefslogtreecommitdiff
path: root/tests/sp_slo_redirect_conf.py
diff options
context:
space:
mode:
authorLorenzo Gil Sanchez <lorenzo.gil.sanchez@gmail.com>2013-04-02 17:07:54 +0200
committerLorenzo Gil Sanchez <lorenzo.gil.sanchez@gmail.com>2013-04-02 17:07:54 +0200
commit2ae12290b0cffe61e981f1ce94d5187f5d66aef8 (patch)
treec2b61e735f185c29f8f9474942654f1195279094 /tests/sp_slo_redirect_conf.py
parentca6afd92fc6730ba17a78de6cb0cef808a8d6d18 (diff)
downloadpysaml2-2ae12290b0cffe61e981f1ce94d5187f5d66aef8.tar.gz
Allow running the tests from the pysaml2 root directory.
This improves previous work for running the tests via the command "python setup.py test" from a fresh clone. This can be very useful to integrate pysaml2 in a continuous integration system such as Jenkins or Travis.
Diffstat (limited to 'tests/sp_slo_redirect_conf.py')
-rw-r--r--tests/sp_slo_redirect_conf.py16
1 files changed, 6 insertions, 10 deletions
diff --git a/tests/sp_slo_redirect_conf.py b/tests/sp_slo_redirect_conf.py
index 21ce49d4..912653e7 100644
--- a/tests/sp_slo_redirect_conf.py
+++ b/tests/sp_slo_redirect_conf.py
@@ -2,11 +2,7 @@ from saml2 import BINDING_HTTP_REDIRECT
from saml2.saml import NAMEID_FORMAT_PERSISTENT
from saml2.saml import NAME_FORMAT_URI
-try:
- from saml2.sigver import get_xmlsec_binary
- xmlsec_path = get_xmlsec_binary(["/opt/local/bin"])
-except ImportError:
- xmlsec_path = '/usr/bin/xmlsec1'
+from pathutils import full_path, xmlsec_path
HOME = "http://lingon.catalogix.se:8087/"
CONFIG = {
@@ -24,15 +20,15 @@ CONFIG = {
"required_attributes": ["surName", "givenName", "mail"],
"optional_attributes": ["title"],
"idp": ["urn:mace:example.com:saml:roland:idp"],
- "subject_data": "subject_data.db",
+ "subject_data": full_path("subject_data.db"),
}
},
"debug" : 1,
- "key_file" : "test.key",
- "cert_file" : "test.pem",
+ "key_file" : full_path("test.key"),
+ "cert_file" : full_path("test.pem"),
"xmlsec_binary" : xmlsec_path,
"metadata": {
- "local": ["idp_slo_redirect.xml"],
+ "local": [full_path("idp_slo_redirect.xml")],
},
"virtual_organization" : {
"urn:mace:example.com:it:tek":{
@@ -41,7 +37,7 @@ CONFIG = {
}
},
"accepted_time_diff": 60,
- "attribute_map_dir" : "attributemaps",
+ "attribute_map_dir" : full_path("attributemaps"),
"organization": {
"name": ("AB Exempel", "se"),
"display_name": ("AB Exempel", "se"),