summaryrefslogtreecommitdiff
path: root/tests/test_31_config.py
diff options
context:
space:
mode:
authorLorenzo Gil Sanchez <lorenzo.gil.sanchez@gmail.com>2013-04-02 17:53:23 +0200
committerLorenzo Gil Sanchez <lorenzo.gil.sanchez@gmail.com>2013-04-02 17:53:23 +0200
commit49d563618ab5c72c5653e97e18117eccfb0bac33 (patch)
tree98ca364be7c42080aa4f01103c00acfc082e9186 /tests/test_31_config.py
parentd179bb012eff1ad0e7a6a66f6966b398b8be6758 (diff)
downloadpysaml2-49d563618ab5c72c5653e97e18117eccfb0bac33.tar.gz
Allow running the tests inside the tests directory
This fix a regression after latest changes. In order to run the tests from the tests directory you will need to install the test_requires packages manually. You can do so with a single command: python setup.py develop easy_install pysaml2[testing] That's why I restored the old extras_requires argument to the setup function. Now it won't duplicate package names but reuse the same ones as in test_requires.
Diffstat (limited to 'tests/test_31_config.py')
-rw-r--r--tests/test_31_config.py10
1 files changed, 5 insertions, 5 deletions
diff --git a/tests/test_31_config.py b/tests/test_31_config.py
index b58da049..68884714 100644
--- a/tests/test_31_config.py
+++ b/tests/test_31_config.py
@@ -11,7 +11,7 @@ from py.test import raises
from saml2 import root_logger
-from pathutils import full_path
+from pathutils import dotname, full_path
sp1 = {
"entityid" : "urn:mace:umu.se:saml:roland:sp",
@@ -297,7 +297,7 @@ def test_conf_syslog():
#noinspection PyUnresolvedReferences
def test_3():
cnf = Config()
- cnf.load_file("tests.sp_1_conf")
+ cnf.load_file(dotname("sp_1_conf"))
assert cnf.entityid == "urn:mace:example.com:saml:roland:sp"
assert cnf.debug == 1
assert cnf.key_file == full_path("test.key")
@@ -310,12 +310,12 @@ def test_3():
def test_sp():
cnf = SPConfig()
- cnf.load_file("tests.sp_1_conf")
+ cnf.load_file(dotname("sp_1_conf"))
assert cnf.endpoint("assertion_consumer_service") == \
["http://lingon.catalogix.se:8087/"]
def test_dual():
- cnf = Config().load_file("tests.idp_sp_conf")
+ cnf = Config().load_file(dotname("idp_sp_conf"))
spe = cnf.getattr("endpoints", "sp")
idpe = cnf.getattr("endpoints", "idp")
@@ -335,7 +335,7 @@ def test_ecp():
def test_assertion_consumer_service():
c = IdPConfig()
- c.load_file("tests.idp_conf")
+ c.load_file(dotname("idp_conf"))
c.context = "idp"
c.metadata.load("local", full_path("InCommon-metadata.xml"))