summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
Diffstat (limited to 'setup.py')
-rwxr-xr-xsetup.py17
1 files changed, 0 insertions, 17 deletions
diff --git a/setup.py b/setup.py
index 682daa2a..d2a57c25 100755
--- a/setup.py
+++ b/setup.py
@@ -6,21 +6,6 @@ import sys
from setuptools import setup
from setuptools.command.test import test as TestCommand
-
-class PyTest(TestCommand):
-
- def finalize_options(self):
- TestCommand.finalize_options(self)
- self.test_args = []
- self.test_suite = True
-
- def run_tests(self):
- #import here, cause outside the eggs aren't loaded
- import pytest
- errno = pytest.main(self.test_args)
- sys.exit(errno)
-
-
install_requires = [
# core dependencies
'decorator',
@@ -85,6 +70,4 @@ setup(
},
install_requires=install_requires,
zip_safe=False,
- test_suite='tests',
- cmdclass={'test': PyTest},
)