summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorEevee (Alex Munroe) <eevee.git@veekun.com>2013-10-08 18:37:37 -0700
committerEevee (Alex Munroe) <eevee.git@veekun.com>2013-10-08 18:37:47 -0700
commit88b16868798e37638da65347b2c90b52b9af5489 (patch)
tree33202f1e417aa6bc1084876d426f7d87efc2de90
parentcc707da913884b92318aa920c19c91f54c8be33f (diff)
downloadpyscss-88b16868798e37638da65347b2c90b52b9af5489.tar.gz
Include speedups header files in an sdist.
-rw-r--r--MANIFEST.in1
-rw-r--r--setup.py2
2 files changed, 3 insertions, 0 deletions
diff --git a/MANIFEST.in b/MANIFEST.in
index 0e7ad4d..5949e0c 100644
--- a/MANIFEST.in
+++ b/MANIFEST.in
@@ -1 +1,2 @@
include DESCRIPTION LICENSE README.rst
+include scss/src/*.h
diff --git a/setup.py b/setup.py
index a8001df..054e86b 100644
--- a/setup.py
+++ b/setup.py
@@ -22,6 +22,8 @@ speedups = Feature(
'optional C speed-enhancement module',
standard=True,
ext_modules=[
+ # NOTE: header files are included by MANIFEST.in; Extension does not
+ # include headers in an sdist (since they're typically in /usr/lib)
Extension(
'scss._speedups',
sources=['scss/src/_speedups.c', 'scss/src/block_locator.c', 'scss/src/scanner.c'],