summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorEevee (Alex Munroe) <eevee.git@veekun.com>2013-10-08 14:52:42 -0700
committerEevee (Alex Munroe) <eevee.git@veekun.com>2013-10-08 14:52:42 -0700
commitcc707da913884b92318aa920c19c91f54c8be33f (patch)
tree2401676cbd54ee509c8bb2d9d9dd3e9c89115dd9
parent2c10593a7bcec17b8d3dcca9ba40e24868f8ca5c (diff)
downloadpyscss-cc707da913884b92318aa920c19c91f54c8be33f.tar.gz
Fix setup.py, probably.
- tests.rst is gone. - We work on 2 and 3 with the same codebase; no need for 2to3. - Don't recursively include EVERYTHING in the manifest.
-rw-r--r--MANIFEST.in1
-rw-r--r--scss/scss_meta.py2
-rw-r--r--setup.py7
3 files changed, 1 insertions, 9 deletions
diff --git a/MANIFEST.in b/MANIFEST.in
index cce0106..0e7ad4d 100644
--- a/MANIFEST.in
+++ b/MANIFEST.in
@@ -1,2 +1 @@
include DESCRIPTION LICENSE README.rst
-recursive-include scss *
diff --git a/scss/scss_meta.py b/scss/scss_meta.py
index 9f3c71f..02ed114 100644
--- a/scss/scss_meta.py
+++ b/scss/scss_meta.py
@@ -44,7 +44,7 @@ xCSS:
"""
-VERSION_INFO = (1, 2, 0)
+VERSION_INFO = (1, 2, 0, 'post2')
DATE_INFO = (2013, 10, 8) # YEAR, MONTH, DAY
VERSION = '.'.join(str(i) for i in VERSION_INFO)
REVISION = '%04d%02d%02d' % DATE_INFO
diff --git a/setup.py b/setup.py
index a2ee273..a8001df 100644
--- a/setup.py
+++ b/setup.py
@@ -37,11 +37,6 @@ if sys.platform == 'win32' and sys.version_info > (2, 6):
ext_errors += (IOError,)
-extra = {}
-if sys.version_info >= (3, 0):
- extra['use_2to3'] = True
-
-
class BuildFailed(Exception):
pass
@@ -112,14 +107,12 @@ def run_setup(with_binary):
'scss.functions',
'scss.functions.compass',
],
- package_data={'scss': ['tests.rst']},
cmdclass={'build_ext': ve_build_ext},
features=features,
entry_points="""
[console_scripts]
pyscss = scss.tool:main
""",
- **extra
)