summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGerman M. Bravo <german.mb@deipi.com>2011-05-13 11:47:26 -0500
committerGerman M. Bravo <german.mb@deipi.com>2011-05-13 11:47:26 -0500
commit2e5a37806a38a653451b489a92c501e458dd8eab (patch)
treef2a9be26e7ea3f989054f455acecfaabe49e4f30
parent5a2d0cee7b0b3999b6385e0fd317a99389806e7c (diff)
downloadpyscss-2e5a37806a38a653451b489a92c501e458dd8eab.tar.gz
Module renamed back to scss, src-color default to blackv1.0
-rw-r--r--CHANGELOG7
-rw-r--r--pyScss.egg-info/PKG-INFO2
-rw-r--r--pyScss.egg-info/SOURCES.txt5
-rw-r--r--pyScss.egg-info/entry_points.txt2
-rw-r--r--pyScss.egg-info/top_level.txt2
-rw-r--r--pyscss/__init__.py0
-rw-r--r--scss/__init__.py (renamed from pyscss/scss.py)4
-rw-r--r--scss/scss_meta.py (renamed from pyscss/scss_meta.py)4
-rw-r--r--setup.py6
9 files changed, 19 insertions, 13 deletions
diff --git a/CHANGELOG b/CHANGELOG
new file mode 100644
index 0000000..0b5f454
--- /dev/null
+++ b/CHANGELOG
@@ -0,0 +1,7 @@
+Changelog
+=========
+
+1.0.8 - May 13, 2011
+ + Changed source color ($src-color) default to black.
+ + Moved the module filename to __init__.py and module renamed back to scss.
+
diff --git a/pyScss.egg-info/PKG-INFO b/pyScss.egg-info/PKG-INFO
index 06b7bcb..67ec6a8 100644
--- a/pyScss.egg-info/PKG-INFO
+++ b/pyScss.egg-info/PKG-INFO
@@ -1,6 +1,6 @@
Metadata-Version: 1.0
Name: pyScss
-Version: 1.0.7
+Version: 1.0.8
Summary: pyScss, a Scss compiler for Python
Home-page: http://github.com/Kronuz/pyScss
Author: German M. Bravo (Kronuz)
diff --git a/pyScss.egg-info/SOURCES.txt b/pyScss.egg-info/SOURCES.txt
index ab653e9..fc63236 100644
--- a/pyScss.egg-info/SOURCES.txt
+++ b/pyScss.egg-info/SOURCES.txt
@@ -8,6 +8,5 @@ pyScss.egg-info/SOURCES.txt
pyScss.egg-info/dependency_links.txt
pyScss.egg-info/entry_points.txt
pyScss.egg-info/top_level.txt
-pyscss/__init__.py
-pyscss/scss.py
-pyscss/scss_meta.py \ No newline at end of file
+scss/__init__.py
+scss/scss_meta.py \ No newline at end of file
diff --git a/pyScss.egg-info/entry_points.txt b/pyScss.egg-info/entry_points.txt
index e65a1e1..e9a9501 100644
--- a/pyScss.egg-info/entry_points.txt
+++ b/pyScss.egg-info/entry_points.txt
@@ -1,4 +1,4 @@
[console_scripts]
- pyscss = pyscss.scss:main
+ pyscss = scss:main
\ No newline at end of file
diff --git a/pyScss.egg-info/top_level.txt b/pyScss.egg-info/top_level.txt
index 0217c38..a419809 100644
--- a/pyScss.egg-info/top_level.txt
+++ b/pyScss.egg-info/top_level.txt
@@ -1 +1 @@
-pyscss
+scss
diff --git a/pyscss/__init__.py b/pyscss/__init__.py
deleted file mode 100644
index e69de29..0000000
--- a/pyscss/__init__.py
+++ /dev/null
diff --git a/pyscss/scss.py b/scss/__init__.py
index 3d63baa..ce65ad4 100644
--- a/pyscss/scss.py
+++ b/scss/__init__.py
@@ -2374,7 +2374,7 @@ def _sprite_map(g, **kwargs):
offset += sizes[i][0] + spacing[1]
if dst_color:
- src_color = ColorValue(src_color).value[:3] if src_color else (255, 0, 255)
+ src_color = ColorValue(src_color).value[:3] if src_color else (0, 0, 0)
dst_color = list(ColorValue(dst_color).value[:3])
pixdata = new_image.load()
for y in xrange(new_image.size[1]):
@@ -2654,7 +2654,7 @@ def _image_url(image, dst_color=None, src_color=None):
filetime = 'NA'
BASE_URL = STATIC_URL
if path:
- src_color = tuple( int(round(c)) for c in ColorValue(src_color).value[:3] ) if src_color else (255, 0, 255)
+ src_color = tuple( int(round(c)) for c in ColorValue(src_color).value[:3] ) if src_color else (0, 0, 0)
dst_color = [ int(round(c)) for c in ColorValue(dst_color).value[:3] ]
file_name, file_ext = os.path.splitext(os.path.normpath(file).replace('\\', '_').replace('/', '_'))
diff --git a/pyscss/scss_meta.py b/scss/scss_meta.py
index bb762e7..f93b4c4 100644
--- a/pyscss/scss_meta.py
+++ b/scss/scss_meta.py
@@ -44,8 +44,8 @@ xCSS:
"""
-VERSION_INFO = (1, 0, 7)
-DATE_INFO = (2011, 5, 4) # YEAR, MONTH, DAY
+VERSION_INFO = (1, 0, 8)
+DATE_INFO = (2011, 5, 13) # YEAR, MONTH, DAY
VERSION = '.'.join(str(i) for i in VERSION_INFO)
REVISION = '%04d%02d%02d' % DATE_INFO
BUILD_INFO = "pyScss v" + VERSION + " ("+REVISION+")"
diff --git a/setup.py b/setup.py
index 898b65a..7bf01d0 100644
--- a/setup.py
+++ b/setup.py
@@ -1,7 +1,7 @@
#!/usr/bin/env python
from setuptools import setup
-from pyscss.scss_meta import PROJECT, URL, VERSION, AUTHOR, AUTHOR_EMAIL, LICENSE, DOWNLOAD_URL
+from scss.scss_meta import PROJECT, URL, VERSION, AUTHOR, AUTHOR_EMAIL, LICENSE, DOWNLOAD_URL
def read(fname):
import os
@@ -25,7 +25,7 @@ setup(name=PROJECT,
author_email=AUTHOR_EMAIL,
url=URL,
download_url=DOWNLOAD_URL,
- packages=['pyscss'],
+ packages=['scss'],
license=LICENSE,
keywords='css oocss xcss sass scss less precompiler',
classifiers=["Development Status :: 5 - Production/Stable",
@@ -40,7 +40,7 @@ setup(name=PROJECT,
],
entry_points = """
[console_scripts]
- pyscss = pyscss.scss:main
+ pyscss = scss:main
""",
**extra
)