summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChris Liechti <cliechti@gmx.net>2016-07-11 23:32:21 +0200
committerChris Liechti <cliechti@gmx.net>2016-07-11 23:32:21 +0200
commitd389f8accff2e20c2bad6eee988ba0d0d1c7fafd (patch)
treebc998b39657abf81b34e7682219c10729e1de7f2
parent26fb4947318a65b6b71f1ec40cf88230f1c95b90 (diff)
downloadpyserial-git-d389f8accff2e20c2bad6eee988ba0d0d1c7fafd.tar.gz
docs: minor update
-rw-r--r--documentation/appendix.rst2
-rw-r--r--documentation/pyserial.rst28
2 files changed, 13 insertions, 17 deletions
diff --git a/documentation/appendix.rst b/documentation/appendix.rst
index 0710f6f..aff9cdd 100644
--- a/documentation/appendix.rst
+++ b/documentation/appendix.rst
@@ -77,7 +77,7 @@ User supplied URL handlers
On Debian based systems, serial ports are usually in the group ``dialout``,
so running ``sudo adduser $USER dialout`` (and logging-out and -in) enables
- the user to use the port.
+ the user to access the port.
Related software
diff --git a/documentation/pyserial.rst b/documentation/pyserial.rst
index 2a7fe42..939882a 100644
--- a/documentation/pyserial.rst
+++ b/documentation/pyserial.rst
@@ -53,7 +53,7 @@ Requirements
Installation
============
-pyserial
+pySerial
--------
This installs a package that can be used from Python (``import serial``).
@@ -62,37 +62,33 @@ may be required.
From PyPI
~~~~~~~~~
-pySerial can be installed from PyPI, either manually downloading the
-files and installing as described below or using::
+pySerial can be installed from PyPI::
- pip install pyserial
+ python -m pip install pyserial
-or::
-
- easy_install -U pyserial
+Using the `python`/`python3` executable of the desired version (2.x/3.x).
From source (tar.gz or checkout)
~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
-Download the archive from http://pypi.python.org/pypi/pyserial.
+Download the archive from http://pypi.python.org/pypi/pyserial or
+https://github.com/pyserial/pyserial/releases.
Unpack the archive, enter the ``pyserial-x.y`` directory and run::
python setup.py install
-For Python 3.x::
-
- python3 setup.py install
+Using the `python`/`python3` executable of the desired version (2.x/3.x).
Packages
~~~~~~~~
There are also packaged versions for some Linux distributions and Windows:
Debian/Ubuntu
- A package is available under the name "python-serial". Note that some
- distributions may package an older version of pySerial.
+ A package is available under the name "python-serial" or similar. Note
+ that some distributions may package an older version of pySerial.
Windows
- There is also a Windows installer for end users. It is located in the
- PyPi_. Developers also may be interested to get the source archive,
+ There is a "wheel" file for end users. It is located in the PyPi_.
+ Developers also may be interested to get the source archive,
because it contains examples, tests and the this documentation.
.. _PyPi: http://pypi.python.org/pypi/pyserial
@@ -115,7 +111,7 @@ Older versions are still available in the old download_ page. pySerial 1.21
is compatible with Python 2.0 on Windows, Linux and several un*x like systems,
MacOSX and Jython.
-On Windows releases older than 2.5 will depend on pywin32_ (previously known as
+On Windows, releases older than 2.5 will depend on pywin32_ (previously known as
win32all)
.. _download: https://pypi.python.org/pypi/pyserial