summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorcliechti <cliechti@f19166aa-fa4f-0410-85c2-fa1106f25c8a>2003-03-19 02:33:54 +0000
committercliechti <cliechti@f19166aa-fa4f-0410-85c2-fa1106f25c8a>2003-03-19 02:33:54 +0000
commit49a8ecf01ee3800a46ad53f11abef5ebf198d8e4 (patch)
tree0d9f85e7affadd0ca8fe585d7d2d81663ef7ad1b
parent6c468b3dfeaaa3c6f4bab5426ab668b4ac7fae67 (diff)
downloadpyserial-git-49a8ecf01ee3800a46ad53f11abef5ebf198d8e4.tar.gz
release 0.1 updates
-rw-r--r--pyparallel/MANIFEST20
-rw-r--r--pyparallel/README.txt11
-rw-r--r--pyparallel/parallel/__init__.py8
-rw-r--r--pyparallel/setup.py17
4 files changed, 34 insertions, 22 deletions
diff --git a/pyparallel/MANIFEST b/pyparallel/MANIFEST
index 72f39fd..b392dc3 100644
--- a/pyparallel/MANIFEST
+++ b/pyparallel/MANIFEST
@@ -2,7 +2,19 @@ README.txt
LICENSE.txt
CHANGES.txt
setup.py
-parallel\__init__.py
-parallel\_pyparallel.py
-examples\test.py
-
+parallel/__init__.py
+parallel/parallelwin32.py
+parallel/parallelppdev.py
+examples/test.py
+src/win32/_pyparallel.c
+src/win32/README.txt
+src/win32/install_giveio.bat
+src/win32/remove_giveio.bat
+src/win32/giveio.sys
+src/win32/giveio/GIVEIO.C
+src/win32/giveio/MAKEFILE
+src/win32/giveio/README.TXT
+src/win32/giveio/SOURCES
+src/win32/loaddrv_console/loaddrv.c
+src/win32/loaddrv_console/loaddrv.h
+src/win32/loaddrv_console/makefile
diff --git a/pyparallel/README.txt b/pyparallel/README.txt
index e6e0734..4f744ec 100644
--- a/pyparallel/README.txt
+++ b/pyparallel/README.txt
@@ -1,8 +1,7 @@
pyParallel
--------
-This module capsulates the access for the parallel port. It provides backends
-for standard Python running on Windows, Linux, BSD and Jython.
-The module named "parallel" automaticaly selects the appropriate backend.
+This module encapsulates the access for the parallel port. It provides
+backends for standard Python running on Windows and Linux.
It is released under a free software license, see LICENSE.txt for more
details.
@@ -14,15 +13,10 @@ Project Homepage: pyserial.sourceforge.net
Features
--------
- same class based interface on all supported platforms
-- port numbering starts at zero, no need to know the platform dependant port
- name in the user program
-- port name can be specified if access through numbering is inappropriate
Requirements
------------
- Python 2.0 or newer (1.5.2 untested)
-- "Java Communications" (JavaComm) extension for Java/Jython
-
Installation
------------
@@ -42,5 +36,4 @@ Short introduction
References
----------
- Python: http://www.python.org
-
- Jython: http://www.jython.org
diff --git a/pyparallel/parallel/__init__.py b/pyparallel/parallel/__init__.py
index 6809355..7b967f9 100644
--- a/pyparallel/parallel/__init__.py
+++ b/pyparallel/parallel/__init__.py
@@ -6,14 +6,16 @@
# this is distributed under a free software license, see license.txt
import sys, os, string
-VERSION = string.split("$Revision: 1.2 $")[1] #extract CVS version
+VERSION = string.split("$Revision: 1.3 $")[1] #extract CVS version
#chose an implementation, depending on os
if os.name == 'nt':
from parallelwin32 import *
elif os.name == 'posix':
- #from parallelposix import *
- from parallelppdev import * #only ppdev for now
+ if sys.platform == 'linux2':
+ from parallelppdev import * #linux, kernel 2.4
+ else:
+ from parallelioctl import * #IOCTLs
elif os.name == 'java':
from paralleljava import *
else:
diff --git a/pyparallel/setup.py b/pyparallel/setup.py
index 64bda13..929277a 100644
--- a/pyparallel/setup.py
+++ b/pyparallel/setup.py
@@ -1,6 +1,16 @@
#!/usr/bin/env python
from distutils.core import setup, Extension
+import os
+if os.name == 'nt':
+ ext_modules =[
+ Extension('_pyparallel',
+ sources=['src/win32/_pyparallel.c'],
+ )
+ ]
+else:
+ ext_modules = None
+
setup (name = "pyparallel",
description="Python Parallel Port Extension",
version="0.1",
@@ -10,10 +20,5 @@ setup (name = "pyparallel",
packages=['parallel'],
license="Python",
long_description="Python Parallel Port Extension for Win32, Linux, BSD",
-
- ext_modules = [
- Extension('_pyparallel',
- sources=['src/win32/_pyparallel.c', 'src/win32/loaddrv.c'],
- )
- ]
+ ext_modules = ext_modules
)