summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorcliechti <cliechti@f19166aa-fa4f-0410-85c2-fa1106f25c8a>2009-07-30 21:15:57 +0000
committercliechti <cliechti@f19166aa-fa4f-0410-85c2-fa1106f25c8a>2009-07-30 21:15:57 +0000
commit8450857e236d5dad30828c3a508167e23b6a7aad (patch)
tree1cddb6b1bc6a804061c1bca9123eaaeef8d49e62
parent05e6f796daa4285d7db4e71dae6cc47b12194374 (diff)
downloadpyserial-git-8450857e236d5dad30828c3a508167e23b6a7aad.tar.gz
- move documentation so that distutils sees it
- update CHANGES.txt - install miniterm.py as script - version 2.5-rc1
-rw-r--r--pyserial/CHANGES.txt18
-rw-r--r--pyserial/MANIFEST.in9
-rw-r--r--pyserial/documentation/Makefile (renamed from documentation/Makefile)0
-rw-r--r--pyserial/documentation/appendix.rst (renamed from documentation/appendix.rst)0
-rw-r--r--pyserial/documentation/conf.py (renamed from documentation/conf.py)0
-rw-r--r--pyserial/documentation/examples.rst (renamed from documentation/examples.rst)0
-rw-r--r--pyserial/documentation/index.rst (renamed from documentation/index.rst)0
-rw-r--r--pyserial/documentation/pyparallel.rst (renamed from documentation/pyparallel.rst)0
-rw-r--r--pyserial/documentation/pyserial.png (renamed from documentation/pyserial.png)bin7050 -> 7050 bytes
-rw-r--r--pyserial/documentation/pyserial.rst (renamed from documentation/pyserial.rst)0
-rw-r--r--pyserial/documentation/pyserial_api.rst (renamed from documentation/pyserial_api.rst)0
-rw-r--r--pyserial/documentation/shortintro.rst (renamed from documentation/shortintro.rst)0
-rw-r--r--pyserial/setup.py4
13 files changed, 16 insertions, 15 deletions
diff --git a/pyserial/CHANGES.txt b/pyserial/CHANGES.txt
index ac44032..9029b9f 100644
--- a/pyserial/CHANGES.txt
+++ b/pyserial/CHANGES.txt
@@ -18,7 +18,7 @@ Bugfixes:
- Win32, when not specifying a timeout
- Typos in the Docs
-
+
New Features:
- added ``serialutil`` which provides a base class for the ``Serial``
@@ -120,7 +120,7 @@ Bugfixes (win32):
- remove send timeout (its not used in the linux impl. anyway).
-Version 1.21 30 sep 2003
+Version 1.21 30 Sep 2003
---------------------------
Bugfixes (win32):
@@ -241,12 +241,9 @@ New Features:
- iterator interface. ``for line in Serial(...): ...`` is now possible
Suggested by Bernhard Bender
-
- ``sendBreak()`` accepts a ``duration`` argument. Default duration increased.
-
- win32 handles \\.\COMx format automatically for com ports of higher number
(COM10 is internally translated to \\.\COM10 etc.)
-
- miniterm.py has a new feature to send a file (upload) and configurable
special characters for exit and upload. Refactored internals to class based
structure (upload and class refactoring by Colin D Bennett)
@@ -302,11 +299,16 @@ Version 2.5 <date>
---------------------------
New Features:
-- 1.5 stop bits (STOPBITS_ONE_POINT_FIVE, implemented on all platforms)
-- miniterm application extended
-- add scanlinux.py example
+- Python 3.x support (through 2to3)
+- compatible with Python io library (Python 2.6+)
- Support for Win32 is now written on the top of ctypes (bundled with
Python 2.5+) instead of pywin32 (patch by Giovanni Bajo).
+- 1.5 stop bits (STOPBITS_ONE_POINT_FIVE, implemented on all platforms)
+- Documentation update, now written with Sphinx/ReST
+- miniterm application extended (CTRL+T -> menu)
+- miniterm.py is now installed as "script"
+- add scanlinux.py example
+- add port_publisher example
Bugfixes:
diff --git a/pyserial/MANIFEST.in b/pyserial/MANIFEST.in
index 4727016..24429f0 100644
--- a/pyserial/MANIFEST.in
+++ b/pyserial/MANIFEST.in
@@ -22,9 +22,8 @@ include examples/wxSerialConfigDialog.wxg
include examples/wxTerminal.py
include examples/wxTerminal.wxg
-#include scripts/python-miniterm
-
-#include ../documentation/*.rst
-#include ../documentation/conf.py
-#include ../documentation/Makefile
+include documentation/*.rst
+include documentation/pyserial.png
+include documentation/conf.py
+include documentation/Makefile
diff --git a/documentation/Makefile b/pyserial/documentation/Makefile
index 8384360..8384360 100644
--- a/documentation/Makefile
+++ b/pyserial/documentation/Makefile
diff --git a/documentation/appendix.rst b/pyserial/documentation/appendix.rst
index 001c6e5..001c6e5 100644
--- a/documentation/appendix.rst
+++ b/pyserial/documentation/appendix.rst
diff --git a/documentation/conf.py b/pyserial/documentation/conf.py
index 7420982..7420982 100644
--- a/documentation/conf.py
+++ b/pyserial/documentation/conf.py
diff --git a/documentation/examples.rst b/pyserial/documentation/examples.rst
index 283f2d6..283f2d6 100644
--- a/documentation/examples.rst
+++ b/pyserial/documentation/examples.rst
diff --git a/documentation/index.rst b/pyserial/documentation/index.rst
index 96a78b5..96a78b5 100644
--- a/documentation/index.rst
+++ b/pyserial/documentation/index.rst
diff --git a/documentation/pyparallel.rst b/pyserial/documentation/pyparallel.rst
index 00c0b95..00c0b95 100644
--- a/documentation/pyparallel.rst
+++ b/pyserial/documentation/pyparallel.rst
diff --git a/documentation/pyserial.png b/pyserial/documentation/pyserial.png
index 7fd45f4..7fd45f4 100644
--- a/documentation/pyserial.png
+++ b/pyserial/documentation/pyserial.png
Binary files differ
diff --git a/documentation/pyserial.rst b/pyserial/documentation/pyserial.rst
index 2db8c21..2db8c21 100644
--- a/documentation/pyserial.rst
+++ b/pyserial/documentation/pyserial.rst
diff --git a/documentation/pyserial_api.rst b/pyserial/documentation/pyserial_api.rst
index 9833254..9833254 100644
--- a/documentation/pyserial_api.rst
+++ b/pyserial/documentation/pyserial_api.rst
diff --git a/documentation/shortintro.rst b/pyserial/documentation/shortintro.rst
index 048f94d..048f94d 100644
--- a/documentation/shortintro.rst
+++ b/pyserial/documentation/shortintro.rst
diff --git a/pyserial/setup.py b/pyserial/setup.py
index 03ff8e3..b4a2fba 100644
--- a/pyserial/setup.py
+++ b/pyserial/setup.py
@@ -28,7 +28,7 @@ if sys.version < '2.3':
setup(
name = "pyserial" + suffix,
description = "Python Serial Port Extension",
- version = "2.4",
+ version = "2.5-rc1",
author = "Chris Liechti",
author_email = "cliechti@gmx.net",
url = "http://pyserial.sourceforge.net/",
@@ -61,5 +61,5 @@ setup(
platforms = 'any',
cmdclass = {'build_py': build_py},
- #~ scripts = ['scripts/pyserial-miniterm'],
+ scripts = ['examples/miniterm.py'],
)