summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorcliechti <cliechti@f19166aa-fa4f-0410-85c2-fa1106f25c8a>2009-07-25 01:15:00 +0000
committercliechti <cliechti@f19166aa-fa4f-0410-85c2-fa1106f25c8a>2009-07-25 01:15:00 +0000
commitff94563d7c82c3581eebf641ea95997616ce9918 (patch)
treec9e939a7e4ae793178ed8d702019ec82c64c7ba0
parent4428a5a77e908ed1d658b964c8ef360e3fd3a4af (diff)
downloadpyserial-git-ff94563d7c82c3581eebf641ea95997616ce9918.tar.gz
adjust some details
-rw-r--r--pyserial/setup.py15
1 files changed, 9 insertions, 6 deletions
diff --git a/pyserial/setup.py b/pyserial/setup.py
index 9a2d657..f9c41ef 100644
--- a/pyserial/setup.py
+++ b/pyserial/setup.py
@@ -1,4 +1,8 @@
-# setup.py
+# setup.py for pyserial
+#
+# windows installer:
+# python setup.py bdist_wininst
+
import sys
from distutils.core import setup
@@ -10,12 +14,9 @@ except ImportError:
raise ImportError("build_py_2to3 not found in distutils - it is required for Python 3.x")
from distutils.command.build_py import build_py
-# windows installer:
-# python setup.py bdist_wininst
-
-# patch distutils if it can't cope with the "classifiers" or
-# "download_url" keywords
if sys.version < '2.2.3':
+ # distutils that old can't cope with the "classifiers" or
+ # "download_url" keywords and True/False constants are missing
raise ValueError("Sorry Python versions older than 2.2.3 are no longer"
"supported - check http://pyserial.sf.net for older "
"releases or upgrade your Python installation.")
@@ -38,6 +39,7 @@ setup(
'Natural Language :: English',
'Operating System :: POSIX',
'Operating System :: Microsoft :: Windows',
+ #~ 'Operating System :: Microsoft :: Windows :: Windows CE', # could work due to new ctypes impl. someone needs to confirm that
'Programming Language :: Python',
'Programming Language :: Python :: 2',
'Programming Language :: Python :: 2.3',
@@ -49,6 +51,7 @@ setup(
'Programming Language :: Python :: 3.1',
'Topic :: Communications',
'Topic :: Software Development :: Libraries',
+ 'Topic :: Software Development :: Libraries :: Python Modules',
'Topic :: Terminals :: Serial',
],
platforms = 'any',