summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorcliechti <cliechti@f19166aa-fa4f-0410-85c2-fa1106f25c8a>2002-12-06 00:21:52 +0000
committercliechti <cliechti@f19166aa-fa4f-0410-85c2-fa1106f25c8a>2002-12-06 00:21:52 +0000
commit33b040d48ec037c790e2946046405464138f4bda (patch)
tree5218e9e506185bb21ff86fdacc8e3766a227d6b4
parentf5831e06b5cb0cb5da4142ca60b5a73ff41830d3 (diff)
downloadpyserial-git-33b040d48ec037c790e2946046405464138f4bda.tar.gz
prepare for release 1.18
-rw-r--r--pyserial/CHANGES.txt17
-rw-r--r--pyserial/README.txt7
-rw-r--r--pyserial/setup.py3
3 files changed, 21 insertions, 6 deletions
diff --git a/pyserial/CHANGES.txt b/pyserial/CHANGES.txt
index ebd38c8..d875ab3 100644
--- a/pyserial/CHANGES.txt
+++ b/pyserial/CHANGES.txt
@@ -11,7 +11,8 @@ Version 1.1 14 Feb 2002
- Typos in the Docs
New Features:
- - added serialutil which provides a base class for the Serial objects.
+ - added serialutil which provides a base class for the Serial
+ objects.
- readline, readlines, writelines and flush are now supported
see README.txt for deatils.
@@ -44,3 +45,17 @@ Version 1.16 02 Jul 2002
Version 1.17 03 Jul 2002
silly mix of two versions in win32 code corrected
+Version 1.18 06 Dec 2002
+ Bugfixes (general):
+ - remove the mapping of flush to the destructive flushOutput as this
+ is not the expected behaviour
+ - readline: EOL character for lines can be chosen idea by John Florian
+ Bugfixes (posix):
+ - cygwin port numbering fixed
+ - test each and every constant for it's existence in termios module,
+ use default if not existent (fix for Bug item #640214)
+ - wrong exception on nonexitstent ports with /dev file. bug report
+ by Louis Cordier
+ Bugfixes (win32):
+ - RTS/CTS handling as sugested in Bug #635072
+ - bugfix of timeouts brought up by Markus Hoffrogge
diff --git a/pyserial/README.txt b/pyserial/README.txt
index d3022a9..5236941 100644
--- a/pyserial/README.txt
+++ b/pyserial/README.txt
@@ -25,7 +25,7 @@ Features
- The files in this package are 100% pure Python.
They depend on non standard but common packages on Windows (win32all) and
Jython (JavaComm). POSIX (Linux, BSD) uses only modules from the standard
- python distribution)
+ Python distribution)
- The port is set up for binary transmission. No NULL byte stripping, CR-LF
translation etc. (which are many times enabled for POSIX.) This makes this
module universally useful.
@@ -93,8 +93,9 @@ ser = serial.Serial(
rtscts=0, #enable RTS/CTS flow control
)
-The port is immediatley opened on object creation. Options:
-timeout=None # wait forever
+The port is immediately opened on object creation.
+Options for read timeout:
+timeout=None #wait forever
timeout=0 #non-blocking mode (return immediately on read)
timeout=x #set timeout to x seconds (float allowed)
diff --git a/pyserial/setup.py b/pyserial/setup.py
index 9664a81..76566ac 100644
--- a/pyserial/setup.py
+++ b/pyserial/setup.py
@@ -1,6 +1,5 @@
# setup.py
from distutils.core import setup
-from glob import glob
#windows installer:
# python setup.py bdist_wininst
@@ -8,7 +7,7 @@ from glob import glob
setup(
name="pyserial",
description="Python Serial Port Extension",
- version="1.17",
+ version="1.18",
author="Chris Liechti",
author_email="cliechti@gmx.net",
url="http://pyserial.sourceforge.net/",