summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorcliechti <cliechti@f19166aa-fa4f-0410-85c2-fa1106f25c8a>2003-09-30 00:01:02 +0000
committercliechti <cliechti@f19166aa-fa4f-0410-85c2-fa1106f25c8a>2003-09-30 00:01:02 +0000
commit3a77ac83b99ff59b507450091d3989eb83f91540 (patch)
tree2e8cc7d7d871f8729c173b868d366ad8cb7b35c0
parentafc28a2850a2c8ac8db22f87beb454eb243f3d08 (diff)
downloadpyserial-git-3a77ac83b99ff59b507450091d3989eb83f91540.tar.gz
updated for release 1.21
-rw-r--r--pyserial/CHANGES.txt5
-rw-r--r--pyserial/serial/serialwin32.py4
-rw-r--r--pyserial/setup.py2
3 files changed, 8 insertions, 3 deletions
diff --git a/pyserial/CHANGES.txt b/pyserial/CHANGES.txt
index cbd8937..fcdf51b 100644
--- a/pyserial/CHANGES.txt
+++ b/pyserial/CHANGES.txt
@@ -74,3 +74,8 @@ Version 1.20 28 Aug 2003
- don't set unneded event masks
- dont use DOS device names for ports > 9
- remove send timeout (its not used in the linux impl. anyway)
+
+
+Version 1.21 30 sep 2003
+ Bugfixes (win32):
+ - name for COM10 was not built correctly, found by Norm Davis
diff --git a/pyserial/serial/serialwin32.py b/pyserial/serial/serialwin32.py
index 2946f47..e428bb5 100644
--- a/pyserial/serial/serialwin32.py
+++ b/pyserial/serial/serialwin32.py
@@ -11,7 +11,7 @@ import win32con # constants.
import sys, string
import serialutil
-VERSION = string.split("$Revision: 1.23 $")[1] #extract CVS version
+VERSION = string.split("$Revision: 1.24 $")[1] #extract CVS version
PARITY_NONE, PARITY_EVEN, PARITY_ODD = range(3)
STOPBITS_ONE, STOPBITS_TWO = (1, 2)
@@ -26,7 +26,7 @@ MS_RING_ON = 64
MS_RLSD_ON = 128
def device(portnum):
- #the "//./COMx" format is required for devices > 9
+ #the "//./COMx" format is required for devices >= 9
#not all versions of windows seem to support this propperly
#so that the first few ports are used with the DOS device name
if portnum < 9:
diff --git a/pyserial/setup.py b/pyserial/setup.py
index 61acc2c..d5a908d 100644
--- a/pyserial/setup.py
+++ b/pyserial/setup.py
@@ -7,7 +7,7 @@ from distutils.core import setup
setup(
name="pyserial",
description="Python Serial Port Extension",
- version="1.20",
+ version="1.21",
author="Chris Liechti",
author_email="cliechti@gmx.net",
url="http://pyserial.sourceforge.net/",