summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorcliechti <cliechti@f19166aa-fa4f-0410-85c2-fa1106f25c8a>2004-07-28 00:52:06 +0000
committercliechti <cliechti@f19166aa-fa4f-0410-85c2-fa1106f25c8a>2004-07-28 00:52:06 +0000
commitaf3dfd59c12d667d73b753db1a82fbb8c87a0403 (patch)
tree10edcca7414de8bdd816f9e15e82ce2b8ba99479
parent6a200bc412a76253664da415615fc31c2a8f0a07 (diff)
downloadpyserial-git-af3dfd59c12d667d73b753db1a82fbb8c87a0403.tar.gz
release 2.1
-rw-r--r--pyserial/CHANGES.txt14
-rw-r--r--pyserial/LICENSE.txt2
-rw-r--r--pyserial/MANIFEST2
-rw-r--r--pyserial/README.txt21
-rw-r--r--pyserial/setup.py2
5 files changed, 32 insertions, 9 deletions
diff --git a/pyserial/CHANGES.txt b/pyserial/CHANGES.txt
index fa8c257..d8b7211 100644
--- a/pyserial/CHANGES.txt
+++ b/pyserial/CHANGES.txt
@@ -135,8 +135,18 @@ Version 2.0b2 4 Oct 2003
Version 2.0 6 Nov 2003
- Fixes setup.py for older distutils
-Version 2.1 XXXXXXXXXXX
+Version 2.1 28 Jul 2004
+ Bugfixes:
+ - Fix XON/XOFF values [Bug 975250]
Bugfixes (posix):
- fd == 0 fix from Vsevolod Lobko
+ - netbsd fixes from Erik Lindgren
+ - Dynamicaly lookup baudrates and some cleanups
+ Bugfixes (examples):
+ - CRLF handling of miniterm.py should be more consistent on Win32
+ and others. Added LF only command line option
+ - Mutithreading fixes to wxTerminal.py (helps with wxGTK)
+ - Small change for wxPython 2.5 in wxSerialConfigDialog.py [Bug 994856]
+
New Features:
- - implement write timeouts ('writeTimeout' parameter)
+ - Implement write timeouts ('writeTimeout' parameter)
diff --git a/pyserial/LICENSE.txt b/pyserial/LICENSE.txt
index 72f0b89..12eddd3 100644
--- a/pyserial/LICENSE.txt
+++ b/pyserial/LICENSE.txt
@@ -1,4 +1,4 @@
-Copyright (c) 2001 Chris Liechti <cliechti@gmx.net>;
+Copyright (c) 2001-2004 Chris Liechti <cliechti@gmx.net>;
All Rights Reserved.
This is the Python license. In short, you can use this product in
diff --git a/pyserial/MANIFEST b/pyserial/MANIFEST
index 01baf94..c702a42 100644
--- a/pyserial/MANIFEST
+++ b/pyserial/MANIFEST
@@ -17,4 +17,4 @@ examples\wxSerialConfigDialog.py
examples\wxSerialConfigDialog.wxg
examples\wxTerminal.py
examples\wxTerminal.wxg
-
+examples\setup_demo.py
diff --git a/pyserial/README.txt b/pyserial/README.txt
index d29bbd6..522c1d5 100644
--- a/pyserial/README.txt
+++ b/pyserial/README.txt
@@ -9,7 +9,7 @@ It is released under a free software license, see LICENSE.txt for more
details.
Project Homepage: pyserial.sourceforge.net
-(C) 2001-2003 Chris Liechti <cliechti@gmx.net>
+(C) 2001-2004 Chris Liechti <cliechti@gmx.net>
Features
@@ -133,6 +133,7 @@ ser = serial.Serial(
timeout=None, #set a timeout value, None to wait forever
xonxoff=0, #enable software flow control
rtscts=0, #enable RTS/CTS flow control
+ writeTimeout=None, #set a timeout for writes
)
The port is immediately opened on object creation, if a port is given.
@@ -143,6 +144,10 @@ timeout=None #wait forever
timeout=0 #non-blocking mode (return immediately on read)
timeout=x #set timeout to x seconds (float allowed)
+Options for write timeout:
+writeTimeout=x #will rise a SerialTimeoutException if the data
+ #cannot be sent in x seconds
+
Methods of Serial instances
---------------------------
open() #open port
@@ -171,15 +176,19 @@ PARITIES #list of valid parities
STOPBITS #list of valid stop bit widths
New values can be assigned to the following attribues, the port
-will be reconfigured, even if it's opened at that time:
+will be reconfigured, even if it's opened at that time (port will be
+closed and reopened to apply the changes):
port #port name/number as set by the user
baudrate #current baudrate setting
bytesize #bytesize in bits
parity #parity setting
stopbits #stop bit with (1,2)
-timeout #timeout setting
+timeout #read timeout setting
xonxoff #if Xon/Xoff flow control is enabled
rtscts #if hardware flow control is enabled
+writeTimeout #write timeout setting
+
+These attribues also have corresponding getX and setXX methods.
Exceptions
----------
@@ -200,6 +209,10 @@ bytesize:
serial.SEVENBITS
serial.EIGHTBITS
+Xon/Xoff characters:
+ serial.XON
+ serial.XOFF
+
Tips & Tricks
-------------
- Some protocols need CR LF ("\r\n") as line terminator, not just LF ("\n").
@@ -209,7 +222,7 @@ Tips & Tricks
some platforms. Look at the tools from Roger Binns:
http://cvs.sourceforge.net/cgi-bin/viewcvs.cgi/bitpim/comscan/
-- When packagin a project with py2exe, it will likely print a warning about
+- When packaging a project with py2exe, it will likely print a warning about
missing modules 'javax.comm'. This warning is uncritical as the module is
used in the Jython implementation that is not used but packaged.
diff --git a/pyserial/setup.py b/pyserial/setup.py
index 6d109f9..edf608e 100644
--- a/pyserial/setup.py
+++ b/pyserial/setup.py
@@ -15,7 +15,7 @@ if sys.version < '2.2.3':
setup(
name="pyserial",
description="Python Serial Port Extension",
- version="2.0",
+ version="2.1",
author="Chris Liechti",
author_email="cliechti@gmx.net",
url="http://pyserial.sourceforge.net/",