summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorcliechti <cliechti@f19166aa-fa4f-0410-85c2-fa1106f25c8a>2004-04-18 00:04:00 +0000
committercliechti <cliechti@f19166aa-fa4f-0410-85c2-fa1106f25c8a>2004-04-18 00:04:00 +0000
commit6ac115b52dfbc2bc71538445b9d1c11fad7251c4 (patch)
treef30a7fb9adc6ce75beae31030f13f830271b1eba
parent5499022589aa708716c1ce85474ac81e6e049815 (diff)
downloadpyserial-git-6ac115b52dfbc2bc71538445b9d1c11fad7251c4.tar.gz
update with text from the homepage (forgot to commit some time ago)
-rw-r--r--pyparallel/README.txt44
1 files changed, 34 insertions, 10 deletions
diff --git a/pyparallel/README.txt b/pyparallel/README.txt
index 4f744ec..55c9760 100644
--- a/pyparallel/README.txt
+++ b/pyparallel/README.txt
@@ -1,39 +1,63 @@
-pyParallel
+pyParallel [in developement]
+============================
+
+Overview
--------
This module encapsulates the access for the parallel port. It provides
-backends for standard Python running on Windows and Linux.
+backends for Python running on Windows and Linux. Other platforms are
+possible too but not yet integrated.
+
+This module is still under developement. But it may be useful for
+developers.
+The windows version needs a compiled extension and the giveio.sys driver
+for Windows NT/2k/XP. The extension module can be compiled with distutils
+with either MSVC or GCC/mingw32.
It is released under a free software license, see LICENSE.txt for more
details.
-Project Homepage: pyserial.sourceforge.net
-(C) 2002 Chris Liechti <cliechti@gmx.net>
+(C) 2001-2003 Chris Liechti cliechti@gmx.net
+Homepage: http://pyserial.sf.net
Features
--------
-- same class based interface on all supported platforms
+ * same class based interface on all supported platforms
+ * port numbering starts at zero, no need to know the port name in the
+ user program
+ * port string (device name) can be specified if access through numbering
+ is inappropriate
Requirements
------------
-- Python 2.0 or newer (1.5.2 untested)
+ * Python 2.2 or newer
+ * "Java Communications" (JavaComm) extension for Java/Jython
Installation
------------
Extract files from the archive, open a shell/console in that directory and
-let Distutils do the rest: "python setup.py install"
+let Disutils do the rest:
+python setup.py install
The files get installed in the "Lib/site-packages" directory in newer
Python versions.
-
Short introduction
------------------
>>> import parallel
>>> p = parallel.Parallel() #open LPT1
>>> p.setData(0x55)
+Examples
+--------
+Please look in the CVS Repository. There is an example directory where you
+can find a simple terminal and more.
+http://cvs.sourceforge.net/cgi-bin/viewcvs.cgi/pyserial/pyparallel/examples/
+
References
----------
-- Python: http://www.python.org
-- Jython: http://www.jython.org
+ * Python: http://www.python.org
+ * Jython: http://www.jython.org
+ * Java@IBM http://www-106.ibm.com/developerworks/java/jdk/ (JavaComm
+ links are on the download page for the respecive platform jdk)
+ * Java@SUN http://java.sun.com/products/