summaryrefslogtreecommitdiff
path: root/examples/setup-wxTerminal-py2exe.py
diff options
context:
space:
mode:
authorcliechti <cliechti@f19166aa-fa4f-0410-85c2-fa1106f25c8a>2010-07-22 00:28:51 +0000
committercliechti <cliechti@f19166aa-fa4f-0410-85c2-fa1106f25c8a>2010-07-22 00:28:51 +0000
commitbfd7c372c99f0c07da9a3bda4685dc33ee06cd91 (patch)
treec7395ee8a5572de19c1f1da77f56d15a03941897 /examples/setup-wxTerminal-py2exe.py
parentc323f1faf74302209d73c6752d4f68a82a93541b (diff)
downloadpyserial-git-bfd7c372c99f0c07da9a3bda4685dc33ee06cd91.tar.gz
tag for release 2.5release2_5
Diffstat (limited to 'examples/setup-wxTerminal-py2exe.py')
-rw-r--r--examples/setup-wxTerminal-py2exe.py35
1 files changed, 35 insertions, 0 deletions
diff --git a/examples/setup-wxTerminal-py2exe.py b/examples/setup-wxTerminal-py2exe.py
new file mode 100644
index 0000000..21b9c94
--- /dev/null
+++ b/examples/setup-wxTerminal-py2exe.py
@@ -0,0 +1,35 @@
+# This is a setup.py example script for the use with py2exe
+from distutils.core import setup
+import py2exe
+import sys, os
+
+#this script is only useful for py2exe so just run that distutils command.
+#that allows to run it with a simple double click.
+sys.argv.append('py2exe')
+
+#get an icon from somewhere.. the python installation should have one:
+icon = os.path.join(os.path.dirname(sys.executable), 'py.ico')
+
+setup(
+ options = {'py2exe': {
+ 'excludes': ['javax.comm'],
+ 'optimize': 2,
+ 'dist_dir': 'dist',
+ }
+ },
+
+ name = "wxTerminal",
+ windows = [
+ {
+ 'script': "wxTerminal.py",
+ 'icon_resources': [(0x0004, icon)]
+ },
+ ],
+ zipfile = "stuff.lib",
+
+ description = "Simple serial terminal application",
+ version = "0.1",
+ author = "Chris Liechti",
+ author_email = "cliechti@gmx.net",
+ url = "http://pyserial.sf.net",
+)