summaryrefslogtreecommitdiff
path: root/examples/setup-wxTerminal-py2exe.py
diff options
context:
space:
mode:
authorcliechti <cliechti@f19166aa-fa4f-0410-85c2-fa1106f25c8a>2013-10-17 16:04:58 +0000
committercliechti <cliechti@f19166aa-fa4f-0410-85c2-fa1106f25c8a>2013-10-17 16:04:58 +0000
commit8bec55528827d09937f411e27195ec396993d75c (patch)
treeaae3383121e8513390cfa7362de60348e0e45699 /examples/setup-wxTerminal-py2exe.py
parent5425bb0510ab10b4601139b7fec64a61e2aec543 (diff)
downloadpyserial-git-8bec55528827d09937f411e27195ec396993d75c.tar.gz
Diffstat (limited to 'examples/setup-wxTerminal-py2exe.py')
-rw-r--r--examples/setup-wxTerminal-py2exe.py35
1 files changed, 35 insertions, 0 deletions
diff --git a/examples/setup-wxTerminal-py2exe.py b/examples/setup-wxTerminal-py2exe.py
new file mode 100644
index 0000000..21b9c94
--- /dev/null
+++ b/examples/setup-wxTerminal-py2exe.py
@@ -0,0 +1,35 @@
+# This is a setup.py example script for the use with py2exe
+from distutils.core import setup
+import py2exe
+import sys, os
+
+#this script is only useful for py2exe so just run that distutils command.
+#that allows to run it with a simple double click.
+sys.argv.append('py2exe')
+
+#get an icon from somewhere.. the python installation should have one:
+icon = os.path.join(os.path.dirname(sys.executable), 'py.ico')
+
+setup(
+ options = {'py2exe': {
+ 'excludes': ['javax.comm'],
+ 'optimize': 2,
+ 'dist_dir': 'dist',
+ }
+ },
+
+ name = "wxTerminal",
+ windows = [
+ {
+ 'script': "wxTerminal.py",
+ 'icon_resources': [(0x0004, icon)]
+ },
+ ],
+ zipfile = "stuff.lib",
+
+ description = "Simple serial terminal application",
+ version = "0.1",
+ author = "Chris Liechti",
+ author_email = "cliechti@gmx.net",
+ url = "http://pyserial.sf.net",
+)