summaryrefslogtreecommitdiff
path: root/examples
diff options
context:
space:
mode:
authorChris Liechti <cliechti@gmx.net>2015-08-09 02:37:45 +0200
committerChris Liechti <cliechti@gmx.net>2015-08-09 02:37:45 +0200
commitfbdd8a0b2aa56e36cca8ec86bf10c4f923a0e6ec (patch)
tree92226d23c031ef645995a76ceffe4c21f2f2dc36 /examples
parente2c31194a29d7d89d890f619295711e823445d15 (diff)
downloadpyserial-git-fbdd8a0b2aa56e36cca8ec86bf10c4f923a0e6ec.tar.gz
update file headers with license information (SPDX)
Diffstat (limited to 'examples')
-rwxr-xr-xexamples/port_publisher.py4
-rwxr-xr-xexamples/rfc2217_server.py8
-rw-r--r--examples/setup-miniterm-py2exe.py4
-rw-r--r--examples/setup-rfc2217_server-py2exe.py4
-rw-r--r--examples/setup-wxTerminal-py2exe.py11
-rwxr-xr-xexamples/tcp_serial_redirect.py9
-rwxr-xr-xexamples/wxSerialConfigDialog.py9
-rwxr-xr-xexamples/wxTerminal.py7
8 files changed, 43 insertions, 13 deletions
diff --git a/examples/port_publisher.py b/examples/port_publisher.py
index 8786733..a87be65 100755
--- a/examples/port_publisher.py
+++ b/examples/port_publisher.py
@@ -1,4 +1,8 @@
#! /usr/bin/env python
+#
+# (C) 2001-2015 Chris Liechti <cliechti@gmx.net>
+#
+# SPDX-License-Identifier: BSD-3-Clause
"""\
Multi-port serial<->TCP/IP forwarder.
- RFC 2217
diff --git a/examples/rfc2217_server.py b/examples/rfc2217_server.py
index 886925a..fb89627 100755
--- a/examples/rfc2217_server.py
+++ b/examples/rfc2217_server.py
@@ -1,9 +1,11 @@
#!/usr/bin/env python
-
-# (C) 2009 Chris Liechti <cliechti@gmx.net>
+#
# redirect data from a TCP/IP connection to a serial port and vice versa
# using RFC 2217
-
+#
+# (C) 2009 Chris Liechti <cliechti@gmx.net>
+#
+# SPDX-License-Identifier: BSD-3-Clause
import logging
import os
diff --git a/examples/setup-miniterm-py2exe.py b/examples/setup-miniterm-py2exe.py
index 0df67ee..0bc5c19 100644
--- a/examples/setup-miniterm-py2exe.py
+++ b/examples/setup-miniterm-py2exe.py
@@ -1,4 +1,8 @@
# setup script for py2exe to create the miniterm.exe
+#
+# (C) 2001-2015 Chris Liechti <cliechti@gmx.net>
+#
+# SPDX-License-Identifier: BSD-3-Clause
from distutils.core import setup
import glob
diff --git a/examples/setup-rfc2217_server-py2exe.py b/examples/setup-rfc2217_server-py2exe.py
index 4c98dd7..04670ca 100644
--- a/examples/setup-rfc2217_server-py2exe.py
+++ b/examples/setup-rfc2217_server-py2exe.py
@@ -1,4 +1,8 @@
# setup script for py2exe to create the rfc2217_server.exe
+#
+# (C) 2001-2015 Chris Liechti <cliechti@gmx.net>
+#
+# SPDX-License-Identifier: BSD-3-Clause
from distutils.core import setup
import glob
diff --git a/examples/setup-wxTerminal-py2exe.py b/examples/setup-wxTerminal-py2exe.py
index 018515b..9e0add7 100644
--- a/examples/setup-wxTerminal-py2exe.py
+++ b/examples/setup-wxTerminal-py2exe.py
@@ -1,14 +1,19 @@
# This is a setup.py example script for the use with py2exe
+#
+# (C) 2001-2015 Chris Liechti <cliechti@gmx.net>
+#
+# SPDX-License-Identifier: BSD-3-Clause
+
from distutils.core import setup
import os
import sys
import py2exe
-#this script is only useful for py2exe so just run that distutils command.
-#that allows to run it with a simple double click.
+# this script is only useful for py2exe so just run that distutils command.
+# that allows to run it with a simple double click.
sys.argv.append('py2exe')
-#get an icon from somewhere.. the python installation should have one:
+# get an icon from somewhere.. the python installation should have one:
icon = os.path.join(os.path.dirname(sys.executable), 'py.ico')
setup(
diff --git a/examples/tcp_serial_redirect.py b/examples/tcp_serial_redirect.py
index e821b74..0ac5c5a 100755
--- a/examples/tcp_serial_redirect.py
+++ b/examples/tcp_serial_redirect.py
@@ -1,9 +1,10 @@
#!/usr/bin/env python
-
+#
+# Redirect data from a TCP/IP connection to a serial port and vice versa.
+#
# (C) 2002-2009 Chris Liechti <cliechti@gmx.net>
-# redirect data from a TCP/IP connection to a serial port and vice versa
-# requires Python 2.2 'cause socket.sendall is used
-
+#
+# SPDX-License-Identifier: BSD-3-Clause
import sys
import os
diff --git a/examples/wxSerialConfigDialog.py b/examples/wxSerialConfigDialog.py
index 6b1a1db..3a2a83d 100755
--- a/examples/wxSerialConfigDialog.py
+++ b/examples/wxSerialConfigDialog.py
@@ -1,7 +1,12 @@
#!/usr/bin/env python
-# generated by wxGlade 0.3.1 on Thu Oct 02 23:25:44 2003
+#
+# A serial port configuration dialog for wxPython. A number of flags can
+# be used to cinfugure the fields that are displayed.
+#
+# (C) 2001-2015 Chris Liechti <cliechti@gmx.net>
+#
+# SPDX-License-Identifier: BSD-3-Clause
-#from wxPython.wx import *
import wx
import serial
import serial.tools.list_ports
diff --git a/examples/wxTerminal.py b/examples/wxTerminal.py
index 5ba8ba7..47ee698 100755
--- a/examples/wxTerminal.py
+++ b/examples/wxTerminal.py
@@ -1,5 +1,10 @@
#!/usr/bin/env python
-# generated by wxGlade 0.3.1 on Fri Oct 03 23:23:45 2003
+#
+# A simple terminal application with wxPython.
+#
+# (C) 2001-2015 Chris Liechti <cliechti@gmx.net>
+#
+# SPDX-License-Identifier: BSD-3-Clause
#from wxPython.wx import *
import wx